summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilhelm Schuster2022-11-01 20:20:21 +0100
committerWilhelm Schuster2022-11-01 20:20:21 +0100
commitb41a24e30f065bfe8c187fdfeb26a030404871bc (patch)
tree52c1a47db86f8b7d26a811a7648193c5d2a0c6bc
parent795bd055a2b2cea2495da53580ca8fce36389971 (diff)
downloadaur-b41a24e30f065bfe8c187fdfeb26a030404871bc.tar.gz
Use vite for building and remove npm workaround
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 3 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47c0c74e8859..2ffae02f062f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fluidd-git
pkgdesc = Klipper web frontend
- pkgver = r1053.003c25a
+ pkgver = r1332.f14173f2
pkgrel = 1
url = https://docs.fluidd.xyz/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index d5b884ab9de7..078dfd272ea3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Wilhelm Schuster <aur [aT] rot13 dot io>
pkgname=fluidd-git
_pkgname="${pkgname%-git}"
-pkgver=r1053.003c25a
+pkgver=r1332.f14173f2
pkgrel=1
pkgdesc="Klipper web frontend"
arch=(any)
@@ -28,7 +28,7 @@ build() {
cd "$srcdir/$_pkgname"
npm install --no-update-notifier --no-audit --cache "${srcdir}/npm-cache"
- ./node_modules/.bin/vue-cli-service build
+ ./node_modules/.bin/vite build
}
package() {
@@ -37,10 +37,6 @@ package() {
install -dm755 "${pkgdir}/usr/share/webapps"
cp -r dist "$pkgdir/usr/share/webapps/${_pkgname}"
- # Non-deterministic race in npm gives 777 permissions to random directories.
- # See https://github.com/npm/cli/issues/1103 for details.
- find "${pkgdir}/usr" -type d -exec chmod 755 {} +
-
# npm gives ownership of ALL FILES to build user
# https://bugs.archlinux.org/task/63396
chown -R root:root "${pkgdir}"