summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2018-10-16 18:49:02 -0400
committerJames P. Harvey2018-10-16 18:49:02 -0400
commitb41b680f50e63690aac628a3502e2c84ba8f649b (patch)
treef710357c1352ee755daf1a9f8535fa8d3324a26e
parentf5fb457b8d80149d4a2a6600b5be3b353568a272 (diff)
downloadaur-b41b680f50e63690aac628a3502e2c84ba8f649b.tar.gz
Depend on rdma-core instead of libibumad. Modernized PKGBUILD. Added some comments to opensm{.launch,.service,_extra.conf}.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--opensm.launch5
-rw-r--r--opensm.service3
-rw-r--r--opensm_extra.conf4
5 files changed, 30 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d95cc8a504b4..bd13f2604722 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = opensm-systemd-multiple-interfaces
pkgdesc = OpenFabrics Alliance InfiniBand Subnet Manager and Administrator
pkgver = 3.3.21
- pkgrel = 1
+ pkgrel = 2
url = https://www.openfabrics.org/index.php/overview.html
arch = x86_64
arch = i686
license = GPL2
license = custom:"Open Fabrics Alliance BSD"
- depends = libibumad
- depends = rdma
+ depends = rdma-core
+ depends = bash
provides = opensm
conflicts = opensm
source = https://github.com/linux-rdma/opensm/archive/3.3.21.tar.gz
source = opensm.service
source = opensm.launch
source = opensm_extra.conf
- md5sums = 7149ad46987749ae80a00124dd1e3f9d
- md5sums = d70efe82917527515520aca4fff840e9
- md5sums = b8827f86be787ede5093c7395bb03928
- md5sums = 733983c333d652907145a7ae8ab09d85
+ sha256sums = 50d024090dc083274bc840792a3b539ecee5ad37a42948f43e84068e42b89b48
+ sha256sums = a40c8a556cb170d84ffb49791fb82aabb21dc4afd22865e8f264a93c1f304788
+ sha256sums = 1ced7ee03c38601b0db84e3b7e69995bd190fd4528548401725fcd6902d8a7c1
+ sha256sums = 1f3f52202f28cb79a5d42fa6812ed6ef2af9844dce0c10063ea1bc1a4644d787
pkgname = opensm-systemd-multiple-interfaces
diff --git a/PKGBUILD b/PKGBUILD
index b5503d5b6556..a1e473e8d377 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,27 @@
-# Maintainer: James Harvey <jamespharvey20@gmail.com>
-# * OpenFabrics Alliance InfiniBand subnet manager (SM) and subnet administrator (SA)
-# * One subnet manager is required to run each InfiniBand subnet, before initializing InfiniBand hardware
-# * No Namcap warnings or errors
-# Up to date with fedora's opensm-3.3.17-5.fc23.src.rpm
+# Maintainer: James P. Harvey <jamespharvey20 at gmail dot com>
pkgname=opensm-systemd-multiple-interfaces
-_pkgbase=opensm
+_pkgname=opensm
pkgver=3.3.21
-pkgrel=1
+pkgrel=2
pkgdesc='OpenFabrics Alliance InfiniBand Subnet Manager and Administrator'
arch=('x86_64' 'i686')
url='https://www.openfabrics.org/index.php/overview.html'
license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
provides=('opensm')
conflicts=('opensm')
-depends=('libibumad' 'rdma')
-source=("https://github.com/linux-rdma/opensm/archive/${pkgver}.tar.gz"
+depends=('rdma-core' 'bash')
+source=("https://github.com/linux-rdma/${_pkgname}/archive/${pkgver}.tar.gz"
'opensm.service'
'opensm.launch'
'opensm_extra.conf')
-md5sums=('7149ad46987749ae80a00124dd1e3f9d'
- 'd70efe82917527515520aca4fff840e9'
- 'b8827f86be787ede5093c7395bb03928'
- '733983c333d652907145a7ae8ab09d85')
+sha256sums=('50d024090dc083274bc840792a3b539ecee5ad37a42948f43e84068e42b89b48'
+ 'a40c8a556cb170d84ffb49791fb82aabb21dc4afd22865e8f264a93c1f304788'
+ '1ced7ee03c38601b0db84e3b7e69995bd190fd4528548401725fcd6902d8a7c1'
+ '1f3f52202f28cb79a5d42fa6812ed6ef2af9844dce0c10063ea1bc1a4644d787')
build() {
- cd "${srcdir}/${_pkgbase}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
./autogen.sh
./configure --prefix=/usr \
--sbindir=/usr/bin \
@@ -37,12 +33,14 @@ build() {
}
package() {
- cd "${srcdir}/${_pkgbase}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
# Convert from init.d to systemd
- rm -rf ${pkgdir}/etc/init.d
+ rm -rf "${pkgdir}/etc/init.d"
+ # ${pkgdir}/etc should now be empty
+ rmdir "${pkgdir}/etc/" > /dev/null
install -Dm644 "${srcdir}/opensm.service" "${pkgdir}/usr/lib/systemd/system/opensm.service"
install -Dm755 "${srcdir}/opensm.launch" "${pkgdir}/usr/bin/opensm.launch"
diff --git a/opensm.launch b/opensm.launch
index 8b721c4bede4..029e4edbea84 100644
--- a/opensm.launch
+++ b/opensm.launch
@@ -1,5 +1,8 @@
#!/bin/bash
-# Copied from Fedora's opensm-3.3.19-1.fc23.src.rpm
+# Upstream doesn't provide a systemd .service file
+# There is a timing bug that intermittently causes signal 15 failures on start
+# Fedora's workaround is to use a separate script
+# Copied from Fedora's opensm-3.3.17-4.fc22.x86_64.rpm
# Modified for Arch
#
# Launch the necessary OpenSM daemons for systemd
diff --git a/opensm.service b/opensm.service
index fd08793117cb..2ceb7b0738f1 100644
--- a/opensm.service
+++ b/opensm.service
@@ -1,4 +1,5 @@
-# Copied from Fedora's opensm-3.3.19-1.fc23.srpm
+# Upstream doesn't provide a systemd .service file
+# Copied from Fedora's opensm-3.3.17-4.fc22.x86_64.rpm
# Modified to follow Arch layout
[Unit]
diff --git a/opensm_extra.conf b/opensm_extra.conf
index 4b76b6ea2787..100737a8e895 100644
--- a/opensm_extra.conf
+++ b/opensm_extra.conf
@@ -1,4 +1,6 @@
-# Copied from Fedora's opensm-3.3.19-1.fc23.src.rpm
+# Upstream doesn't provide a systemd .service file, let alone a way to
+# configure one to run simultaneous multiple interfaces.
+# Copied from Fedora's opensm-3.3.17-4.fc22.x86_64.rpm
# Problem #1: Multiple IB fabrics needing a subnet manager
#
# In the event that a machine has more than one IB subnet attached,