summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalstrond2020-08-04 14:11:15 +0200
committerMalstrond2020-08-04 14:11:15 +0200
commitb42060c9e8f288fcd785a6377709fa7e83920b44 (patch)
tree68ef495e9bb1df4c9aad74ffbe1f87b4a4f516e0
parent5917bc8ecd4fa0d8f2c2677234dd72238efbe307 (diff)
downloadaur-b42060c9e8f288fcd785a6377709fa7e83920b44.tar.gz
Updated, adjusted to upstream changes in architecture, package directory layout and libraries
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD25
-rw-r--r--activityplayer.sh10
-rw-r--r--inspire.sh11
4 files changed, 33 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df99289d21c8..9173c71a4e32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,31 @@
pkgbase = activinspire
pkgdesc = Presentation Software for use with Promethean Hardware products.
- pkgver = 2.18.68238
+ pkgver = 2.19.69200
pkgrel = 0
url = https://support.prometheanworld.com/product/activinspire
arch = x86_64
license = unknown
- depends = lib32-libxmu
- depends = lib32-gst-plugins-base
- depends = lib32-libjpeg-turbo
- depends = lib32-libjpeg6-turbo
- depends = lib32-libxrender
- depends = lib32-libgl
- depends = lib32-fontconfig
- depends = lib32-openssl-1.0
- depends = lib32-nss
- depends = lib32-libxcomposite
- depends = lib32-libxcursor
- depends = lib32-libxtst
- depends = lib32-dbus
- optdepends = bin32-jre: For using the equation editor
+ depends = libxmu
+ depends = gst-plugins-base
+ depends = libjpeg-turbo
+ depends = libxrender
+ depends = libgl
+ depends = fontconfig
+ depends = openssl-1.0
+ depends = nss
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxtst
+ depends = dbus
optdepends = activdriver: Driver for Promethean hardware
optdepends = activtools: Tools for Promethean hardware, e.g. calibration or systray monitor
- source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_2.18.68238-1.amd64_amd64.deb
+ source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_2.19.69200.1804-1.amd64_amd64.deb
source = inspire.sh
source = activityplayer.sh
source = com.ubuntu.user-interface.gschema.xml
- md5sums = 4da7d0533928096ac6f74e37d3a41e88
- md5sums = 21ff8944ba388a6b5aab894839745132
- md5sums = 5222bd85f84f45cd1ebc6ccece49d586
+ md5sums = cf9f58626f00e77fd8991a425b1b946e
+ md5sums = d3096ede6c2cd388469f4e12a8286ee8
+ md5sums = 14f618ed07ed2d267b2578818d253200
md5sums = e0f2c4078eadd00de8f28159b273e576
pkgname = activinspire
diff --git a/PKGBUILD b/PKGBUILD
index 072c5a34764c..e8d94605061f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,27 @@
# Contributor: Bazon <bazonbloch@arcor.de>
pkgname=activinspire
-pkgver=2.18.68238
+pkgver=2.19.69200
pkgrel=0
pkgdesc="Presentation Software for use with Promethean Hardware products."
arch=('x86_64')
url="https://support.prometheanworld.com/product/activinspire"
license=('unknown')
-depends=(lib32-libxmu lib32-gst-plugins-base lib32-libjpeg-turbo lib32-libjpeg6-turbo lib32-libxrender lib32-libgl lib32-fontconfig lib32-openssl-1.0 lib32-nss lib32-libxcomposite lib32-libxcursor lib32-libxtst lib32-dbus)
-optdepends=('bin32-jre: For using the equation editor'
- 'activdriver: Driver for Promethean hardware'
+depends=(libxmu gst-plugins-base libjpeg-turbo libxrender libgl fontconfig openssl-1.0 nss libxcomposite libxcursor libxtst dbus)
+optdepends=('activdriver: Driver for Promethean hardware'
'activtools: Tools for Promethean hardware, e.g. calibration or systray monitor')
-source=("http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_${pkgver}-1.amd64_amd64.deb"
+source=("http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_${pkgver}.1804-1.amd64_amd64.deb"
"inspire.sh"
"activityplayer.sh"
"com.ubuntu.user-interface.gschema.xml")
-md5sums=('4da7d0533928096ac6f74e37d3a41e88'
- '21ff8944ba388a6b5aab894839745132'
- '5222bd85f84f45cd1ebc6ccece49d586'
+md5sums=('cf9f58626f00e77fd8991a425b1b946e'
+ 'd3096ede6c2cd388469f4e12a8286ee8'
+ '14f618ed07ed2d267b2578818d253200'
'e0f2c4078eadd00de8f28159b273e576')
package() {
- # The upstream .deb actually includes 3 whole setups:
- # 1. The actual files to be used by the package manager (in the . directory),
- # 2. a self-contained installer for installing without a package manager (in ./inspire),
- # 3. an older version of ActivInspire (13.x) (in ./inspire/DEB).
- # It also includes /etc/xdg (not needed) and /var/Promethean (created with the correct permissions below).
- # All except #1 are not extracted to save time while removing them.
- bsdtar -C "$pkgdir" --exclude=./inspire --exclude=./var --exclude=./etc -xf data.tar.gz
+ # Extract software from debian archive. Exclude /etc/xdg (not needed) and /var/Promethean (created with the correct permissions below).
+ bsdtar -C "$pkgdir" --exclude=./var --exclude=./etc -xf data.tar.xz
# Use /opt instead of /usr/local/bin for binaries to match Arch packaging standards for large self-contained packages.
install -dm0755 "$pkgdir"/opt
@@ -39,7 +33,6 @@ package() {
# Because we just changed the paths, now we need to fix the absolute paths that Promethean uses in their files.
sed -i "s%/usr/local/bin%/usr/bin%" "$pkgdir"/usr/share/applications/activsoftware.desktop
sed -i "s%/usr/local/bin%/usr/bin%" "$pkgdir"/usr/share/applications/activplayer.desktop
- sed -i "s%/usr/local/bin%/opt%" "$pkgdir"/opt/activsoftware/workbench/activdashboard.sh
# Install com.ubuntu.user-interface schema need to launch ActivInspire.
mkdir "$pkgdir"/usr/share/glib-2.0
diff --git a/activityplayer.sh b/activityplayer.sh
index ae552d3702c7..d705a59af1aa 100644
--- a/activityplayer.sh
+++ b/activityplayer.sh
@@ -2,15 +2,13 @@
# This script launches ActivPlayer. It is partially based on the upstream launch script, with obsolete and Ubuntu-specific stuff fixed or removed.
-cd /opt/activsoftware/workbench
+cd /opt/activsoftware
# Promethean software has a bug that often causes it to hang when attempting to close it using the GUI. So we need to kill those instances before launching a new one.
killall -q activplayer
-# Promethean ships ActivInspire with a bunch of libraries. We can't recompile it and there are less problems when using this library versions.
-export LD_LIBRARY_PATH="/opt/activsoftware:/opt/activsoftware/workbench:/opt/activsoftware/workbench/lib:/opt/activsoftware/32bit_libs_for_64bit_OS:$LD_LIBRARY_PATH"
-export GST_PLUGIN_PATH="/opt/activsoftware/32bit_libs_for_64bit_OS:$GST_PLUGIN_PATH"
-export QTWEBKIT_PLUGIN_PATH="/opt/activsoftware/32bit_libs_for_64bit_OS:$QTWEBKIT_PLUGIN_PATH"
+# Promethean ships ActivInspire with a bunch of libraries. We can't recompile it and there are less problems when using these library versions.
+export LD_LIBRARY_PATH="/opt/activsoftware:$LD_LIBRARY_PATH"
# Launch and open the file if one was given as an argument.
-./activplayer "$@" \ No newline at end of file
+./activplayer "$@"
diff --git a/inspire.sh b/inspire.sh
index 7c594ef3040c..00e15d587080 100644
--- a/inspire.sh
+++ b/inspire.sh
@@ -7,16 +7,11 @@ cd /opt/activsoftware
# Promethean software has a bug that often causes it to hang when attempting to close it using the GUI. So we need to kill those instances before launching a new one.
killall -q Inspire
-# ActivInspire needs 32-bit Java for the equation editor (see optional dependencies).
-export JAVA_HOME=/usr/lib32/jvm/java32-8-jre/jre
-
-# Promethean ships ActivInspire with a bunch of libraries. We can't recompile it and there are less problems when using this library versions.
-export LD_LIBRARY_PATH="/opt/activsoftware:/opt/activsoftware/workbench:/opt/activsoftware/workbench/lib:/opt/activsoftware/32bit_libs_for_64bit_OS:$LD_LIBRARY_PATH"
-export GST_PLUGIN_PATH="/opt/activsoftware/32bit_libs_for_64bit_OS:$GST_PLUGIN_PATH"
-export QTWEBKIT_PLUGIN_PATH="/opt/activsoftware/32bit_libs_for_64bit_OS:$QTWEBKIT_PLUGIN_PATH"
+# Promethean ships ActivInspire with a bunch of libraries. We can't recompile it and there are less problems when using these library versions.
+export LD_LIBRARY_PATH="/opt/activsoftware:$LD_LIBRARY_PATH"
# Launch and open the file if one was given as an argument.
./Inspire "$@"
# This is a lock file. Since ActivInspire hangs when attempting to close it, it never gets deleted, causing problems.
-rm -f /dev/shm/sem.promethean \ No newline at end of file
+rm -f /dev/shm/sem.promethean