summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Robin2015-06-11 20:03:00 +0200
committerBenjamin Robin2015-06-11 20:03:00 +0200
commitb45c297c4a50e3c6d58c06f7b92fdb62a6318ec3 (patch)
treedb38e5e8871434241ecd025dfcc1f7df15b092f8
downloadaur-b45c297c4a50e3c6d58c06f7b92fdb62a6318ec3.tar.gz
Copied from AUR 3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12cfa69f4bfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = eclipse-subversive-svn-connector-svnkit
+ pkgdesc = Subversive SVN Connectors SVN Kit
+ pkgver = 4.1.3.I20150214_1700
+ pkgrel = 1
+ url = http://www.polarion.com/products/svn/subversive.php
+ arch = any
+ license = EPL
+ depends = eclipse-subversive
+ depends = eclipse-subversive-svn-connector
+ noextract = eclipse-subversive-svn-connector-svnkit-4.1.3.I20150214_1700-feature.jar
+ noextract = eclipse-subversive-svn-connector-svnkit-4.1.3.I20150214_1700-plugin.jar
+ source = eclipse-subversive-svn-connector-svnkit-4.1.3.I20150214_1700-feature.jar::http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/features/org.polarion.eclipse.team.svn.connector.svnkit18_4.1.3.I20150214-1700.jar
+ source = eclipse-subversive-svn-connector-svnkit-4.1.3.I20150214_1700-plugin.jar::http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/plugins/org.polarion.eclipse.team.svn.connector.svnkit18_4.1.3.I20150214-1700.jar
+ md5sums = e3821f6ef6cb1df66b74bdab698bd7e5
+ md5sums = 1cfe7214916a184a86891e7ed07c730e
+
+pkgname = eclipse-subversive-svn-connector-svnkit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68f0836e4ce8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Benjamin Robin <benjarobin>
+
+pkgname=eclipse-subversive-svn-connector-svnkit
+pkgver=4.1.3.I20150214_1700
+pkgrel=1
+pkgdesc="Subversive SVN Connectors SVN Kit"
+arch=('any')
+url="http://www.polarion.com/products/svn/subversive.php"
+license=('EPL')
+depends=(eclipse-subversive eclipse-subversive-svn-connector)
+
+source=("$pkgname-$pkgver-feature.jar::http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/features/org.polarion.eclipse.team.svn.connector.svnkit18_${pkgver//_/-}.jar" \
+ "$pkgname-$pkgver-plugin.jar::http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/plugins/org.polarion.eclipse.team.svn.connector.svnkit18_${pkgver//_/-}.jar")
+
+noextract=($pkgname-$pkgver-{feature,plugin}.jar)
+md5sums=('e3821f6ef6cb1df66b74bdab698bd7e5'
+ '1cfe7214916a184a86891e7ed07c730e')
+
+package()
+{
+ _dest="${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse"
+
+ # Feature(s)
+ install -d -m755 $_dest/features/org.polarion.eclipse.team.svn.connector.svnkit_${pkgver//_/-}
+ cd $_dest/features/org.polarion.eclipse.team.svn.connector.svnkit_${pkgver//_/-}
+ jar xf $srcdir/$pkgname-$pkgver-feature.jar
+
+ # Plugin(s)
+ install -D -m644 $srcdir/$pkgname-$pkgver-plugin.jar $_dest/plugins/org.polarion.eclipse.team.svn.connector.svnkit_${pkgver//_/-}.jar
+}
+