summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoonas Henriksson2022-08-10 02:44:07 +0300
committerJoonas Henriksson2022-08-10 03:14:45 +0300
commitb460622cf5537d9159b8db308f6cf7e218fa028c (patch)
tree432473751864e0a4313f136be6bb920a8cee4fde
parent07623b5f6f79a9b78c3167f1800bd00631679db2 (diff)
downloadaur-b460622cf5537d9159b8db308f6cf7e218fa028c.tar.gz
Update against current git code
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
-rw-r--r--floating_wm_workaround.patch14
3 files changed, 37 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc16f9c612e9..e2be75e5ac1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = glslviewer-git
pkgdesc = Live GLSL coding render for MacOS and Linux
- pkgver = r753.8a4f4d7
+ pkgver = r1470.99a990a
pkgrel = 1
url = https://github.com/patriciogonzalezvivo/glslViewer
arch = i686
arch = x86_64
license = BSD-3-Clause
+ makedepends = cmake
makedepends = git
- depends = glfw
- provides = glslviewer-git
- conflicts = glslviewer-git
- source = glslviewer-git::git+https://github.com/patriciogonzalezvivo/glslViewer
- source = floating_wm_workaround.patch
+ depends = glu
+ depends = glfw-x11
+ depends = ncurses
+ depends = ffmpeg
+ provides = glslviewer
+ conflicts = glslviewer
+ source = glslviewer::git+https://github.com/patriciogonzalezvivo/glslViewer
+ source = git+https://github.com/patriciogonzalezvivo/ada
+ md5sums = SKIP
md5sums = SKIP
- md5sums = 20c838d28b2390c9dd6fa3491c920edc
pkgname = glslviewer-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 83af8d828f48..21af84a12c79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,48 @@
-# Maintainer: Agorgianitis Loukas <agorglouk@gmail.com>
+# Maintainer: Joonas Henriksson <joonas.henriksson at gmail com>
+# Contributor: Agorgianitis Loukas <agorglouk@gmail.com>
+
pkgname=glslviewer-git
-pkgver=r753.8a4f4d7
+pkgver=r1470.99a990a
pkgrel=1
pkgdesc="Live GLSL coding render for MacOS and Linux"
arch=('i686' 'x86_64')
url="https://github.com/patriciogonzalezvivo/glslViewer"
license=('BSD-3-Clause')
-depends=('glfw')
-makedepends=('git')
-provides=("${pkgname%-VCS}")
-conflicts=("${pkgname%-VCS}")
-source=("$pkgname::git+https://github.com/patriciogonzalezvivo/glslViewer"
- 'floating_wm_workaround.patch')
+depends=('glu' 'glfw-x11' 'ncurses' 'ffmpeg')
+makedepends=('cmake' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/patriciogonzalezvivo/glslViewer"
+ "git+https://github.com/patriciogonzalezvivo/ada")
md5sums=('SKIP'
- '20c838d28b2390c9dd6fa3491c920edc')
+ 'SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-VCS}"
+ cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/${pkgname%-VCS}"
- patch -p1 -i "$srcdir/floating_wm_workaround.patch"
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git config submodule.deps/ada.url "$srcdir/ada"
+ git submodule update
}
build() {
- cd "$srcdir/${pkgname%-VCS}"
- make
+ cmake \
+ -S "${pkgname%-git}" \
+ -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+ make -C build
}
package() {
- cd "$srcdir/${pkgname%-VCS}"
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m755 bin/glslViewer "$pkgdir/usr/bin/glslviewer"
- install -D -m755 bin/glslLoader "$pkgdir/usr/bin/glslloader"
+ make install -C build DESTDIR="$pkgdir"
+
+ install -D -m644 "${pkgname%-git}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
mkdir -p "$pkgdir/usr/share/$pkgname/examples/"
- cp -R examples/* "$pkgdir/usr/share/$pkgname/examples/"
+ cp -R "${pkgname%-git}"/examples/* "$pkgdir/usr/share/$pkgname/examples/"
chmod -R 755 "$pkgdir/usr/share/$pkgname/examples/"
}
diff --git a/floating_wm_workaround.patch b/floating_wm_workaround.patch
deleted file mode 100644
index 64c4fcc0e220..000000000000
--- a/floating_wm_workaround.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/window.cpp b/src/window.cpp
-index 7b5eb06..d3f6a09 100644
---- a/src/window.cpp
-+++ b/src/window.cpp
-@@ -416,6 +416,9 @@ void initGL (glm::ivec4 &_viewport, WindowStyle _style) {
- else if (_style == ALLWAYS_ON_TOP)
- glfwWindowHint(GLFW_FLOATING, GL_TRUE);
-
-+ // Make it float
-+ glfwWindowHint(GLFW_RESIZABLE, GLFW_FALSE);
-+
- if (_style == FULLSCREEN) {
- GLFWmonitor* monitor = glfwGetPrimaryMonitor();
- const GLFWvidmode* mode = glfwGetVideoMode(monitor);