summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2014-06-20 01:38:17 +0800
committerYen Chi Hsuan2014-06-20 01:38:17 +0800
commitb464ff2158207e43e9820c6136816237bbc97110 (patch)
treef49b38af5aa63027e29802b41d1a36c1e08f1801
downloadaur-b464ff2158207e43e9820c6136816237bbc97110.tar.gz
Add dhcptest-git
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53ddc3e5ad78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dhcptest-git
+ pkgdesc = DHCP test client
+ pkgver = 0.5.r0.g56a8834
+ pkgrel = 3
+ url = https://github.com/CyberShadow/dhcptest
+ arch = i686
+ arch = x86_64
+ license = custom:BSL1.0
+ makedepends = dmd
+ makedepends = git
+ depends = glibc
+ source = dhcptest-git::git+https://github.com/CyberShadow/dhcptest
+ source = http://www.boost.org/LICENSE_1_0.txt
+ md5sums = SKIP
+ md5sums = e4224ccaecb14d942c71d31bef20d78c
+
+pkgname = dhcptest-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43ff39c80917
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+LICENSE_1_0.txt
+# the cloned bare repo
+dhcptest-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e364e44398c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Yen Chi Hsuan <yan12125 at gmail dot com>
+
+pkgname=dhcptest-git
+pkgver=20140406
+pkgrel=1
+pkgdesc="DHCP test client"
+arch=('i686' 'x86_64')
+url="https://github.com/CyberShadow/dhcptest"
+license=('BSL1.0')
+makedepends=('dmd')
+source=("$pkgname"::'git://github.com/CyberShadow/dhcptest'
+ 'http://www.boost.org/LICENSE_1_0.txt')
+md5sums=('SKIP'
+ 'e4224ccaecb14d942c71d31bef20d78c')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ dmd dhcptest.d
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "dhcptest" "$pkgdir/usr/bin/dhcptest"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/dhcptest/README.md"
+ cd "$srcdir"
+ install -Dm644 "LICENSE_1_0.txt" "$pkgdir/usr/share/licenses/dhcptest/LICENSE.txt"
+}
+