summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2021-07-20 11:33:52 +0200
committerAndrea Feletto2021-07-20 11:33:52 +0200
commitb47a3559e4b72a79579c42609a1c9a1f38cdf05a (patch)
treec0a472507c117a38ef757d6672795ea2aee37320
downloadaur-b47a3559e4b72a79579c42609a1c9a1f38cdf05a.tar.gz
version 1.7.2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4968276a86ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gmid-bin
+ pkgdesc = Fast Gemini server written with security in mind.
+ pkgver = 1.7.2
+ pkgrel = 1
+ url = https://gmid.omarpolo.com
+ arch = x86_64
+ license = ISC
+ depends = libretls
+ provides = gmid
+ conflicts = gmid
+ conflicts = gmid-git
+ source = https://github.com/omar-polo/gmid/releases/download/1.7.2/gmid.linux.amd64
+ source = https://raw.githubusercontent.com/omar-polo/gmid/1.7.2/gmid.1
+ source = https://raw.githubusercontent.com/omar-polo/gmid/1.7.2/LICENSE
+ source = https://raw.githubusercontent.com/omar-polo/gmid/1.7.2/README.md
+ sha256sums = f141058d9ec6930b97a67556dc80178ef346d4a7228e0fbaca1afb3dbd44f798
+ sha256sums = 25b39eda4bbf94b8b9e5e04d156ef0bd2a63994766186eaf12aeeb40802571cd
+ sha256sums = f82c1fa80d35427d109a77ed59ecda41474ef46539238750876702fa40579f9f
+ sha256sums = a5917d6f3e0a56612fdae554ed26993282d872a4a8655bcfa9289c9d270e418c
+
+pkgname = gmid-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fecc08f58aad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=gmid-bin
+_pkgname=${pkgname%-*}
+pkgver=1.7.2
+pkgrel=1
+pkgdesc='Fast Gemini server written with security in mind.'
+arch=('x86_64')
+url='https://gmid.omarpolo.com'
+license=('ISC')
+provides=('gmid')
+conflicts=('gmid' 'gmid-git')
+depends=('libretls')
+source=(
+ "https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname.linux.amd64"
+ "https://raw.githubusercontent.com/omar-polo/$_pkgname/$pkgver/gmid.1"
+ "https://raw.githubusercontent.com/omar-polo/$_pkgname/$pkgver/LICENSE"
+ "https://raw.githubusercontent.com/omar-polo/$_pkgname/$pkgver/README.md"
+)
+sha256sums=(
+ 'f141058d9ec6930b97a67556dc80178ef346d4a7228e0fbaca1afb3dbd44f798'
+ '25b39eda4bbf94b8b9e5e04d156ef0bd2a63994766186eaf12aeeb40802571cd'
+ 'f82c1fa80d35427d109a77ed59ecda41474ef46539238750876702fa40579f9f'
+ 'a5917d6f3e0a56612fdae554ed26993282d872a4a8655bcfa9289c9d270e418c'
+)
+
+package() {
+ cd "$srcdir"
+ install -Dm755 "$_pkgname.linux.amd64" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 gmid.1 -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+}