summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2017-01-12 11:07:35 -0700
committernot_anonymous2017-01-12 11:07:35 -0700
commitb47a8de24f3cc97f2f03b6e8b1a5d316f4a6394f (patch)
tree20862be0bc42763593f84ac80b9b67f0019fd25c
downloadaur-b47a8de24f3cc97f2f03b6e8b1a5d316f4a6394f.tar.gz
Added back into aur
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD47
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcbfa70bc5bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = ebook2cw
+ pkgdesc = Converts plain text files to Morse Code formatted as MP3 or OGG
+ pkgver = 0.8.2
+ pkgrel = 5
+ url = http://fkurz.net/ham/ebook2cw.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = lame
+ depends = libvorbis
+ optdepends = mpg123: for CLI playback/testing
+ source = http://fkurz.net/ham/ebook2cw/ebook2cw-0.8.2.tar.gz
+ source = http://fkurz.net/ham/ebook2cw/example/Example.txt
+ source = http://fkurz.net/ham/ebook2cw/example/Chapter00.mp3
+ source = http://fkurz.net/ham/ebook2cw/example/Chapter01.mp3
+ source = http://fkurz.net/ham/ebook2cw/example/Chapter02.mp3
+ md5sums = 2069b3a4a2b21810bbf32532e2287f7d
+ md5sums = 426e3b5ee86806cefbe2a499b4fd35b9
+ md5sums = 52c6884888810f6b7199f004c38608a9
+ md5sums = 4396acf1065cc198bdc545ae83968b19
+ md5sums = d0aa612cdfd651ce03bfead58319b7ed
+ sha256sums = d8277ac6aaf9e64d9cb9a96457488b3a0dbd77e87622ded8f0825acb500c5758
+ sha256sums = 8032dd47c1efbef8f02e3fb421e0c172f7165b7c23b856228c4632a6296d5f26
+ sha256sums = fee8e860f8cea4c5504beb02d12d41795a039e27eb32aab0dd297a37e3ad3103
+ sha256sums = 38a6bee36cf76b9280b66f871a2edd565192b13604b0ed316317027cf9175243
+ sha256sums = 205c95d4b03aca0b9c78681bfe3fcd31354e010076775252851bcc81282e8acb
+
+pkgname = ebook2cw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..576f55b498f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+# Contributor: WB2FKO <mph at sportscliche dot com>
+# Original Submission: Bob Finch <w9ya@qrparci.net>
+
+pkgname=ebook2cw
+pkgver=0.8.2
+pkgrel=5
+pkgdesc="Converts plain text files to Morse Code formatted as MP3 or OGG"
+arch=('i686' 'x86_64')
+url="http://fkurz.net/ham/ebook2cw.html"
+license=('GPL')
+depends=('lame' 'libvorbis')
+optdepends=('mpg123: for CLI playback/testing')
+source=(http://fkurz.net/ham/$pkgname/${pkgname}-${pkgver}.tar.gz
+ http://fkurz.net/ham/$pkgname/example/Example.txt
+ http://fkurz.net/ham/$pkgname/example/Chapter{00,01,02}.mp3)
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+ sed -i s:'#iso':'iso': ebook2cw.conf
+ sed -i s:'#utf':'utf': ebook2cw.conf
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+# make USE_OGG=NO all # <- USE *if* you do not want ogg capability
+ make all
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR="${pkgdir}/usr" install
+
+ mkdir -p $pkgdir/usr/share/$pkgname
+ install -m644 ../Example.txt $pkgdir/usr/share/$pkgname
+ install -m644 ../*.mp3 $pkgdir/usr/share/$pkgname
+}
+md5sums=('2069b3a4a2b21810bbf32532e2287f7d'
+ '426e3b5ee86806cefbe2a499b4fd35b9'
+ '52c6884888810f6b7199f004c38608a9'
+ '4396acf1065cc198bdc545ae83968b19'
+ 'd0aa612cdfd651ce03bfead58319b7ed')
+sha256sums=('d8277ac6aaf9e64d9cb9a96457488b3a0dbd77e87622ded8f0825acb500c5758'
+ '8032dd47c1efbef8f02e3fb421e0c172f7165b7c23b856228c4632a6296d5f26'
+ 'fee8e860f8cea4c5504beb02d12d41795a039e27eb32aab0dd297a37e3ad3103'
+ '38a6bee36cf76b9280b66f871a2edd565192b13604b0ed316317027cf9175243'
+ '205c95d4b03aca0b9c78681bfe3fcd31354e010076775252851bcc81282e8acb')