summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoripochto2021-11-29 11:03:18 +0300
committeripochto2021-11-29 11:03:18 +0300
commitb4928eac8095eb009fc8c03a39ea71ba588313ab (patch)
tree5eb219880ffa086ea10bb3a88ac228821f7843a5
downloadaur-b4928eac8095eb009fc8c03a39ea71ba588313ab.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9df30f7134d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = war1gus
+ pkgdesc = Warcraft1 Mod that allows you to play Warcraft1 with the Stratagus engine
+ pkgver = 3.1.2
+ pkgrel = 1
+ url = https://github.com/Wargus/war1gus
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = imagemagick
+ depends = stratagus=3.1.2
+ depends = ffmpeg
+ depends = innoextract
+ provides = war1gus
+ conflicts = war1gus-git
+ source = https://github.com/Wargus/war1gus/archive/v3.1.2.tar.gz
+ md5sums = 3b0cad05b8b7be117426ab8d1f58bfb5
+
+pkgname = war1gus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7d818d887df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: ipochto <ipochto@gmail.com>
+
+pkgname=war1gus
+pkgver=3.1.2
+pkgrel=1
+pkgdesc="Warcraft1 Mod that allows you to play Warcraft1 with the Stratagus engine"
+arch=("i686" "x86_64")
+url="https://github.com/Wargus/war1gus"
+license=('GPL')
+depends=("stratagus=$pkgver" 'ffmpeg' 'innoextract')
+makedepends=('cmake' 'imagemagick')
+source=("https://github.com/Wargus/$pkgname/archive/v${pkgver}.tar.gz")
+md5sums=('3b0cad05b8b7be117426ab8d1f58bfb5')
+provides=(${pkgname})
+conflicts=('war1gus-git')
+
+build() {
+ cd ${srcdir}
+
+ cmake "${pkgname}-${pkgver}" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DGAMEDIR=/usr/bin -Bbuild
+
+ make -C build
+}
+
+package() {
+ cd $srcdir/build
+ make DESTDIR=${pkgdir} install
+}