summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2019-10-06 02:05:56 +0200
committerRaimar Bühmann2019-10-06 02:05:56 +0200
commitb49f1568ef83e076e7d8cd712d1fe9d4d9c83344 (patch)
treef272adebb565065e7f6b2c64e543bb5dcecb4820
parent8049a5462a426aa95d3277ade3267eeaee33fed0 (diff)
downloadaur-b49f1568ef83e076e7d8cd712d1fe9d4d9c83344.tar.gz
update to 2.19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
2 files changed, 33 insertions, 13 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fa9adc91945d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+eclipse-*.pkg.tar.xz
+EMF-Updates-*.zip
diff --git a/PKGBUILD b/PKGBUILD
index e0cf39668d72..338e55bf8f9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,43 @@
# Contributor: Corrado Primier <bardo@aur.archlinux.org>
# Contributor: Rubin Simons <rubin@xs4all.nl>
# Contributor: Arthur Zamarin <arthurzam@gmail.com>
-# Maintainer: David Rosenstrauch <darose@darose.net>
+# Contributor: David Rosenstrauch <darose@darose.net>
+# Maintainer: Raimar Buehmann <raimar at buehmann dot de>
pkgname=eclipse-emf
-pkgver=2.12.0
+pkgver=2.19
_reldate=201605260356
pkgrel=2
pkgdesc="EMF and XSD frameworks for the Eclipse platform"
arch=('any')
url="http://www.eclipse.org/modeling/emf/"
license=('EPL')
-depends=('eclipse>=3.5')
-_mirror="http://www.eclipse.org/downloads/download.php?r=1&file="
-source=("$_mirror/modeling/emf/emf/downloads/drops/${pkgver}/R${_reldate}/emf-runtime-${pkgver}.zip"
- "$_mirror/modeling/emf/emf/downloads/drops/${pkgver}/R${_reldate}/xsd-runtime-${pkgver}.zip")
-md5sums=('fccaa15ebfc51357ae1d2fffe3574efc'
- 'fce2cc0cd2281d5765e29bf236b5e0be')
+depends=('eclipse')
+makedepends=('java-environment-common')
+options=(!strip)
+# https://download.eclipse.org/modeling/emf/emf/builds/release/2.19/EMF-Updates-2.19.zip
+source=(
+ https://download.eclipse.org/modeling/emf/emf/builds/release/${pkgver}/EMF-Updates-${pkgver}.zip
+)
+sha256sums=('ddd4f9c423b0ff5ea0029acc61cbad8844715561cd6808bdd80d3937ab055693')
package() {
- _dest=$pkgdir/usr/lib/eclipse/dropins/${pkgname#eclipse-}/eclipse
- cd "${srcdir}/eclipse"
- find . -type f | while read f ; do
- install -Dm644 ${f} "${_dest}/${f}"
- done
+ _dest=${pkgdir}/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ install -d $_dest
+ # remove feature sources
+ rm features/*source_*
+ # extract features (otherwise features are not recognized)
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+ # copy plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
}