summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Devlamynck2015-06-10 20:44:11 +0200
committerXavier Devlamynck2015-06-10 20:44:11 +0200
commitb4abbb5968233be3be67731ca21dabfb1aec4095 (patch)
tree8bfca5ff909e3e9ecb2490fe5b3361827b0b5b2f
downloadaur-b4abbb5968233be3be67731ca21dabfb1aec4095.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--patch-limits.h.patch11
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0092640da581
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sipp
+ pkgdesc = A free Open Source test tool / traffic generator for the SIP protocol.
+ pkgver = 3.4.0
+ pkgrel = 2
+ url = http://sipp.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = openssl
+ depends = libpcap
+ depends = lksctp-tools
+ source = https://github.com/SIPp/sipp/archive/3.4.0.tar.gz
+ sha256sums = 6b3a7f7410cac7053500843afe0d0de1c9bd54b8557e09c502a1d4131ab1f986
+
+pkgname = sipp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4aed1474fa6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Xavier Devlamynck <magicrhesus@ouranos.be>
+# Contributor: Aleshus <aleshusi@gmail.com>
+
+pkgname=sipp
+pkgver=3.4.0
+pkgrel=2
+pkgdesc="A free Open Source test tool / traffic generator for the SIP protocol."
+arch=('i686' 'x86_64')
+url="http://sipp.sourceforge.net/"
+license=('GPL')
+depends=('openssl' 'libpcap' 'lksctp-tools')
+source=(https://github.com/SIPp/${pkgname}/archive/${pkgver}.tar.gz)
+sha256sums=('6b3a7f7410cac7053500843afe0d0de1c9bd54b8557e09c502a1d4131ab1f986')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --with-pcap --with-sctp
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D -m0755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/patch-limits.h.patch b/patch-limits.h.patch
new file mode 100644
index 000000000000..0d7e82f1981a
--- /dev/null
+++ b/patch-limits.h.patch
@@ -0,0 +1,11 @@
+diff -urp sipp.svn/scenario.hpp sipp.svn/scenario.hpp.patched
+--- sipp.svn/scenario.hpp 2008-01-08 23:03:23.000000000 +0100
++++ sipp.svn/scenario.hpp.patched 2010-05-13 14:34:41.000000000 +0200
+@@ -30,6 +30,7 @@
+ #include "variables.hpp"
+ #include "message.hpp"
+ #include "stat.hpp"
++#include "limits.h"
+
+
+ #define MSG_TYPE_SENDCMD 0