summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2023-11-12 17:59:10 +0600
committerzoorat2023-11-12 17:59:10 +0600
commitb4c491f0f5d59b69962133413d1374872b148484 (patch)
treee7c44be1e6ca49ecf69a496eaf6eefe22d86f6c1
parent220b3288c3aa4852893832d8c345b834d92bd74f (diff)
downloadaur-b4c491f0f5d59b69962133413d1374872b148484.tar.gz
removing changelog
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore1
-rw-r--r--Makefile24
-rw-r--r--PKGBUILD17
-rw-r--r--changelog.md46
5 files changed, 17 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c657b2e51282..b90b6c74c70d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = python-spotdl
pkgdesc = Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).
pkgver = 4.2.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/spotDL/spotify-downloader
- changelog = changelog.md
arch = any
license = MIT
checkdepends = python-pytest-asyncio
diff --git a/.gitignore b/.gitignore
index fd1cf73e6413..f8b77578b1ca 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,3 @@
!Makefile
!PKGBUILD
!.SRCINFO
-!changelog.md
diff --git a/Makefile b/Makefile
index ffa42df81816..c037a7da1139 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,9 @@
+##
+## This Makefile is just for the maintainer of this package
+## to easily keep this package up to date.
+## This won't have any effect on your build.
+##
+
MAKEFLAGS += --warn-undefined-variables
SHELL=/bin/bash
@@ -6,7 +12,7 @@ VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
TRASH = $(shell git check-ignore * | tr '\n' ' ')
# DEFAULT
-all: clean log sum build check pre clean
+all: clean sum build check pre clean
# just build the package
build:
@@ -23,7 +29,7 @@ sum:
# check/lint
check:
@echo "shellcheck: "
- shellcheck -e SC2148 -e SC2034 PKGBUILD || exit 0
+ shellcheck -e SC2148 -e SC2034 -e SC2164 PKGBUILD || exit 0
@echo "shell formate: "
shfmt -d PKGBUILD || exit 0
@@ -46,19 +52,6 @@ else
fi
endif
-# generate `changelog.md`
-log:
- @echo "wait, it will take some time"
- $(eval NAME := $(shell gh release --repo $(REPO) view --json name | jq -r .name))
- echo "# Name: $(NAME) " >changelog.md
- $(eval URL := $(shell gh release --repo $(REPO) view --json url | jq -r .url))
- echo "### URL: $(URL)" >>changelog.md
- $(eval PUBLISHED_AT := $(shell gh release --repo $(REPO) view --json publishedAt | jq -r .publishedAt))
- $(eval AUTHOR := $(shell gh release --repo $(REPO) view --json author | jq -r .author.login))
- echo "### published at '$(PUBLISHED_AT)' by $(AUTHOR)" >>changelog.md
- echo "---" >>changelog.md
- gh release --repo $(REPO) view --json body | jq -r .body >>changelog.md
-
# prepare for commit
pre:
shfmt -w PKGBUILD
@@ -67,7 +60,6 @@ pre:
git diff
git add PKGBUILD
- git add changelog.md
git add .SRCINFO
git add .gitignore
git add Makefile
diff --git a/PKGBUILD b/PKGBUILD
index 5ad66c2a221a..bcc7a8ea06d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=python-spotdl
pkgver=4.2.1
-pkgrel=2
+pkgrel=3
pkgdesc='Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).'
arch=('any')
@@ -45,7 +45,6 @@ makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry-cor
checkdepends=('python-pytest-asyncio')
provides=("$pkgname" 'spotdl')
options=(strip emptydirs zipman)
-changelog="changelog.md"
source=("https://pypi.io/packages/source/s/spotdl/spotdl-$pkgver.tar.gz")
# source=("https://github.com/spotDL/spotify-downloader/archive/refs/tags/v$pkgver.zip")
@@ -53,21 +52,21 @@ b2sums=('f07541071b20fbb1ab7f98ff9cd1543a62edd52354531bbb2d7f4d4ef508a1d3a7b80a1
# Document: https://wiki.archlinux.org/title/Python_package_guidelines
build() {
- pushd spotdl-$pkgver || exit
+ pushd spotdl-$pkgver
# https://github.com/python-poetry/poetry/issues/5547
- GIT_DIR=. python -m build --wheel --no-isolation
- popd || exit
+ python -m build --wheel --no-isolation
+ popd
}
check() {
- pushd spotdl-$pkgver || exit
+ pushd spotdl-$pkgver
pytest || echo 'Tests failed!'
- popd || exit
+ popd
}
package() {
- pushd spotdl-$pkgver || exit
+ pushd spotdl-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
install -vDm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- popd || exit
+ popd
}
diff --git a/changelog.md b/changelog.md
deleted file mode 100644
index 56b195a61c57..000000000000
--- a/changelog.md
+++ /dev/null
@@ -1,46 +0,0 @@
-# Name: v4.2.1
-### URL: https://github.com/spotDL/spotify-downloader/releases/tag/v4.2.1
-### published at '2023-09-01T22:44:30Z' by xnetcat
----
-## What's Changed
-
-Web:
-- Playlist, artist and album download from web app by @oscarvx00 in #1865
-
-Bugfixes:
-- check if track is a song when downloading playlists by @xnetcat in 8949b9a692c8fabac266f95f2a2a5895daaf7769
-- Support for manual Bandcamp and Soundcloud download. (Using like manual Youtube download in the format MusicURL|SpotifyURL) by @Piripe in #1897
-- Fix crash when filtering results with the --dont-filter-results argument when a provider has 0 result by @Piripe in #1897
-- Fixed a crash with the cache by @Piripe in #1897
-- Fixed matching error when downloading an album caused by track duration by @Piripe in #1897
-- Fixed bandcamp audio provider by @xnetcat in b1a48debc573924d100a91a47f2bc0ab741a51cc a4c6e8dcb80ab99cd62f84b80dcba0ec7a1dadde
-
-Improvements:
-- use downloader settings when parsing query by @xnetcat in 0a692c7b0b0610204908c7823cd14ce078df1b6d
-- added more checks for sync file by @xnetcat in 5e34b216287b84daecf5b26afb6c99b57d4572ab
-- respect detect-formats option when using m3u option by @xnetcat in 8a8891e097480caccbda74b75f5ed1d62bb05f81
-- fixed/improved search term matching by @xnetcat in db11f719d7ba76451e3a7d628909277cab8ac38d
-
-New features:
-- added option to save errors by @xnetcat in 920442e134292e892b762b4fdf7f69aeafc3c972
-- added more checks for sync file
-- added ability to print to stdout when using save by @xnetcat in ce2bce651d46810621ae8eb729bb816ccdd115dc
-- added `all-user-followed-artists` shortcut by @xnetcat in f9f110f61dd7bb388546bd6791da81fbb5d2077f
-
-Misc:
-- updated packages by @xnetcat in f8d749048537239085d7335e24f2f87ed24402ab
-
-**Full Changelog**: https://github.com/spotDL/spotify-downloader/compare/v4.2.0...v4.2.1
-
-## New Contributors
-* @oscarvx00 made their first contribution in https://github.com/spotDL/spotify-downloader/pull/1865
-* @Piripe made their first contribution in https://github.com/spotDL/spotify-downloader/pull/1897
-
-## Donate
-
-help support the development and maintenance of the software ❤️
-
-[![paypal](https://img.shields.io/badge/paypal-%2300457C.svg?&style=for-the-badge&logo=paypal&logoColor=white)](https://paypal.me/kko7)
-[![kofi](https://img.shields.io/badge/kofi-%23F16061.svg?&style=for-the-badge&logo=ko-fi&logoColor=white)](https://ko-fi.com/xnetcat)
-
-