summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek "foxie" Brenčič2021-04-26 23:10:22 +0200
committerMarek "foxie" Brenčič2021-04-26 23:10:22 +0200
commitb4ded2aae641956d0490f8769593d52a40ec5f8f (patch)
tree9f2e88af06d7ad322a40ad671c549cb8975ee0db
parent1f346566c2b263233125ed7973e0f63081ed0645 (diff)
downloadaur-b4ded2aae641956d0490f8769593d52a40ec5f8f.tar.gz
Update to v2
-rw-r--r--PKGBUILD20
-rw-r--r--disig-web-signer.install22
2 files changed, 23 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df145918f686..6150d6eae001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Fedor Piecka <teplavoda at gmail dot com>
pkgname=disig-web-signer
-pkgver=1.1.5
-pkgrel=3
+pkgver=2.0.7
+pkgrel=1
pkgdesc="Slovak eID Web Signer by Disig"
arch=('i686' 'x86_64')
license=('custom')
url="https://zep.disig.sk/"
-source_i686=('https://download.disigcdn.sk/cdn/products/websigner/disig-web-signer.debian_i386.deb')
-source_x86_64=('https://download.disigcdn.sk/cdn/products/websigner/disig-web-signer.debian_amd64.deb')
+source_i686=('https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.debian_i386.deb')
+source_x86_64=('https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.debian_amd64.deb')
md5sums_i686=('SKIP')
md5sums_x86_64=('SKIP')
options=("!strip")
@@ -30,12 +30,16 @@ package() {
ar p ${srcdir}/disig-web-signer.debian_${upstream_arch}.deb data.tar.xz | tar -xJ -C "${pkgdir}"
- # Create a native messaging host for Google Chrome browser (as a link to Chromium version); this is done by a postinst script in upstream Debian package
+ # Create a native messaging host for Google Chrome browser and Chromium; this is done by a postinst script in upstream Debian package
+ native_messaging_host_filename=$(basename $(find ${pkgdir}/opt/disig/websigner/chrome/ -name sk.disig.websigner.*.java.json))
+
mkdir -p ${pkgdir}/etc/opt/chrome/native-messaging-hosts
- native_messaging_host_filename=$(basename $(find ${pkgdir}/etc/chromium/native-messaging-hosts/ -name sk.disig.websigner.*.java.json))
- ln -s /etc/chromium/native-messaging-hosts/${native_messaging_host_filename} ${pkgdir}/etc/opt/chrome/native-messaging-hosts
+ ln -sf ${pkgdir}/opt/disig/websigner/chrome/${native_messaging_host_filename} ${pkgdir}/etc/opt/chrome/native-messaging-hosts/${native_messaging_host_filename}
+
+ mkdir -p ${pkgdir}/etc/chromium/native-messaging-hosts/
+ ln -sf ${pkgdir}/opt/disig/websigner/chrome/${native_messaging_host_filename} ${pkgdir}/etc/chromium/native-messaging-hosts/${native_messaging_host_filename}
# Let autostart configuration up to a user's discretion
- rm -r ${pkgdir}/etc/xdg
+ # rm -r ${pkgdir}/etc/xdg
}
diff --git a/disig-web-signer.install b/disig-web-signer.install
index fa719454f8f1..572b9d0be368 100644
--- a/disig-web-signer.install
+++ b/disig-web-signer.install
@@ -1,12 +1,12 @@
-post_install() {
- echo ">>> disig-web-signer browser addon has NOT been installed into Firefox."
- echo ">>> You can install the plugin into Firefox from the following location:"
- echo -n ">>> "
- ls /opt/disig/websigner/firefox/*.xpi
-}
+# post_install() {
+# echo ">>> disig-web-signer browser addon has NOT been installed into Firefox."
+# echo ">>> You can install the plugin into Firefox from the following location:"
+# echo -n ">>> "
+# ls /opt/disig/websigner/firefox/*.xpi
+# }
-post_upgrade() {
- echo ">>> You may need to upgrade the Firefox addon for disig-web-signer if you use it:"
- echo -n ">>> "
- ls /opt/disig/websigner/firefox/*.xpi
-}
+# post_upgrade() {
+# echo ">>> You may need to upgrade the Firefox addon for disig-web-signer if you use it:"
+# echo -n ">>> "
+# ls /opt/disig/websigner/firefox/*.xpi
+# }