summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicholas Cioli2018-03-20 13:36:06 -0500
committerNicholas Cioli2018-03-20 13:36:06 -0500
commitb4df10e35351714e82505ed604549a2c13e69805 (patch)
treebd46592bd87da7941e47b4874ff5c4db48377c9d
downloadaur-b4df10e35351714e82505ed604549a2c13e69805.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1e1beb823ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dlib-free
+ pkgdesc = C++ library with several utilities. No support for non-free features
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/dorian3d/DLib
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = gcc
+ depends = opencv
+ conflicts = dlib-nonfree
+ source = https://github.com/dorian3d/DLib/archive/v1.1-free.tar.gz
+ md5sums = 808b3aa44eb781012892f6aaa403c3ff
+
+pkgname = dlib-free
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84e1ea9c42ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Nicholas Cioli <nicholascioli+arch@gmail.com>
+pkgname=dlib-free
+pkgver=1.1
+pkgrel=1
+pkgdesc="C++ library with several utilities. No support for non-free features"
+arch=('x86_64')
+url="https://github.com/dorian3d/DLib"
+license=('custom')
+depends=(opencv)
+makedepends=(cmake gcc)
+provides=()
+conflicts=(dlib-nonfree)
+source=(
+ "https://github.com/dorian3d/DLib/archive/v$pkgver-free.tar.gz"
+)
+md5sums=(
+ "808b3aa44eb781012892f6aaa403c3ff"
+)
+
+build() {
+ cd "DLib-$pkgver-free"
+ if [ ! -d build ]; then
+ mkdir build
+ fi
+ cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "DLib-$pkgver-free/build"
+ make DESTDIR="$pkgdir/" install
+
+ # Install the license
+ install -Dm644 ../LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}