summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Delgado2020-12-18 21:09:32 -0500
committerDylan Delgado2020-12-18 21:09:32 -0500
commitb515792d3776f6e5df1d5b130b38d2f229f1f81a (patch)
tree0924c42188b6cb1834d8d33892bcaca8cb4c5b06
downloadaur-b515792d3776f6e5df1d5b130b38d2f229f1f81a.tar.gz
First commit, based on version 1.7.0
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD28
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13008004f5b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-metar
+ pkgdesc = a Python package to parse METAR-coded weather reports
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://github.com/python-metar/python-metar
+ arch = x86_64
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/70/48/c0b746fcccde312d990b43be79726791f0d7b10a099693c520d2d29a85f8/metar-1.7.0.tar.gz
+ source = LICENSE
+ sha256sums = bee673dab1cf3767d5a5fcb8b67a2d0194f686503050ab94ffd08fd9a2f2e1e4
+ sha256sums = SKIP
+
+pkgname = python-metar
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..121f4f326fde
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2004-2018, Tom Pollard
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+ Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a9c3221bd55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#Maintainer: Dylan Delgado <dylan1496 at live dot com>
+
+pkgname=python-metar
+_pipname=metar
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="a Python package to parse METAR-coded weather reports"
+url="https://github.com/python-metar/python-metar"
+arch=('x86_64')
+license=('custom')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/70/48/c0b746fcccde312d990b43be79726791f0d7b10a099693c520d2d29a85f8/${_pipname}-${pkgver}.tar.gz"
+"LICENSE")
+sha256sums=("bee673dab1cf3767d5a5fcb8b67a2d0194f686503050ab94ffd08fd9a2f2e1e4"
+"SKIP")
+
+build() {
+ cd ${srcdir}/${_pipname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pipname}-${pkgver}
+ python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build
+ cd ..
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
+} \ No newline at end of file