summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Ruhier2021-08-10 17:53:03 +0000
committerAnthony Ruhier2021-08-10 17:53:03 +0000
commitb5472d1560ce532ac7816241994ebc7aae260f8d (patch)
treeda7469e139181cc8e972671740dd6dc6b84b81aa
parentf7902d6f52e3647d0eb11dac3d3b293cccaef082 (diff)
downloadaur-b5472d1560ce532ac7816241994ebc7aae260f8d.tar.gz
92b1 update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d05c27ec4f76..c85031edf864 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-beta
pkgdesc = Standalone web browser from mozilla.org - Beta
- pkgver = 91.0b6
+ pkgver = 92.0b1
pkgrel = 1
url = https://www.mozilla.org/en-US/firefox/channel/#beta
arch = i686
@@ -21,7 +21,6 @@ pkgbase = firefox-beta
makedepends = clang
makedepends = llvm
makedepends = jack
- makedepends = gtk2
makedepends = nodejs
makedepends = cbindgen
makedepends = nasm
@@ -43,19 +42,21 @@ pkgbase = firefox-beta
optdepends = pulseaudio: Audio support
optdepends = speech-dispatcher: Text-to-Speech
optdepends = hunspell-en_US: Spell checking, American English
- provides = firefox=91.0b6
+ optdepends = xdg-desktop-portal: Screensharing with Wayland
+ provides = firefox=92.0b1
conflicts = firefox-beta-bin
options = !emptydirs
options = !makeflags
options = !strip
- source = http://archive.mozilla.org/pub/firefox/releases/91.0b6/source/firefox-91.0b6.source.tar.xz
- source = http://archive.mozilla.org/pub/firefox/releases/91.0b6/source/firefox-91.0b6.source.tar.xz.asc
+ source = http://archive.mozilla.org/pub/firefox/releases/92.0b1/source/firefox-92.0b1.source.tar.xz
+ source = http://archive.mozilla.org/pub/firefox/releases/92.0b1/source/firefox-92.0b1.source.tar.xz.asc
source = 0001-Use-remoting-name-for-GDK-application-names.patch
source = firefox-beta.desktop
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
- sha256sums = bd2aba509bcde4030941a690dc9570f65f7efc365ad1235ffabec03121fc9552
+ sha256sums = 0ab670d560428188f64acfd488ec6aef4f300b1a02c78666164c83a43249d9ec
sha256sums = SKIP
sha256sums = 1b6814e85f13dcf069482ad1acfc1a099661922c85e3344aa4ee059288506ccc
sha256sums = 54d93249fedc9c4cdc5eb82da498b08f08bcb089f85a138b457f3251a0913ad1
pkgname = firefox-beta
+
diff --git a/PKGBUILD b/PKGBUILD
index 4dae4f32c732..4691835c143f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,10 +49,10 @@ fi
pkgname=firefox-beta
_pkgname=firefox
-pkgver=91.0b6
+pkgver=92.0b1
_major=${pkgver/rc*}
_build=${pkgver/*rc}
-_pkgver=91.0
+_pkgver=92.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org - Beta"
arch=(i686 x86_64)
@@ -60,20 +60,21 @@ license=(MPL GPL LGPL)
url="https://www.mozilla.org/en-US/firefox/channel/#beta"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
- autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
+ autoconf2.13 rust clang llvm jack nodejs cbindgen nasm
python-setuptools python-psutil python-zstandard lld dump_syms)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech'
- 'hunspell-en_US: Spell checking, American English')
+ 'hunspell-en_US: Spell checking, American English'
+ 'xdg-desktop-portal: Screensharing with Wayland')
provides=("firefox=$pkgver")
conflicts=('firefox-beta-bin')
options=(!emptydirs !makeflags !strip)
-source=(http://archive.mozilla.org/pub/firefox/releases/91.0b6/source/$_pkgname-$pkgver.source.tar.xz{,.asc}
+source=(http://archive.mozilla.org/pub/firefox/releases/${pkgver}/source/$_pkgname-$pkgver.source.tar.xz{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop)
-sha256sums=('bd2aba509bcde4030941a690dc9570f65f7efc365ad1235ffabec03121fc9552'
+sha256sums=('0ab670d560428188f64acfd488ec6aef4f300b1a02c78666164c83a43249d9ec'
'SKIP'
'1b6814e85f13dcf069482ad1acfc1a099661922c85e3344aa4ee059288506ccc'
'54d93249fedc9c4cdc5eb82da498b08f08bcb089f85a138b457f3251a0913ad1')
@@ -119,6 +120,7 @@ ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
ac_add_options --enable-linker=lld
ac_add_options --disable-elf-hack
+ac_add_options --disable-bootstrap
# Branding
ac_add_options --enable-official-branding
@@ -129,7 +131,6 @@ ac_add_options --allow-addon-sideload
export MOZILLA_OFFICIAL=1
export MOZ_APP_REMOTINGNAME=${pkgname//-/}
export MOZ_TELEMETRY_REPORTING=1
-export MOZ_REQUIRE_SIGNING=1
# Keys
ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-key