summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 11:12:04 -0600
committerMark Wagie2022-04-15 11:12:04 -0600
commitb583ca960aa235fa286f7cf8ba5c9a2143a9e1ba (patch)
tree927978b00477d541fff3536e626343ca5853dd7e
parentf00ed236799189a586e01d75b39cac27fd63712b (diff)
downloadaur-b583ca960aa235fa286f7cf8ba5c9a2143a9e1ba.tar.gz
standards based build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b9cb1ead679..707ced9a6554 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = rebound
pkgdesc = Command-line tool that instantly fetches Stack Overflow results when an exception is thrown
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/shobrook/rebound
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-beautifulsoup4
depends = python-requests
depends = python-urwid
diff --git a/PKGBUILD b/PKGBUILD
index f5e9085275b3..c6a8134e8398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,13 @@
pkgname=rebound
_name="$pkgname-cli"
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Command-line tool that instantly fetches Stack Overflow results when an exception is thrown"
arch=('any')
url="https://github.com/shobrook/rebound"
license=('MIT')
depends=('python-beautifulsoup4' 'python-requests' 'python-urwid')
-makedepends=('python-setuptools')
-#checkdepends=('python-pytest')
-#source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('19e2065a140a64abb53d8553b6faa15db89a851e9909225786cb6997e56c03c7')
@@ -23,15 +21,10 @@ prepare() {
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
-#check() {
-# cd "$_name-$pkgver"
-# pytest
-#}
-
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}