summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCastix2021-05-22 15:40:36 +0200
committerCastix2021-05-22 15:48:28 +0200
commitb59853f7e19639c51fb9c564a63a004f488dfa30 (patch)
tree6ce585806bfe86123982cdb0f33d748dbb838fb8
parent968baa02b44a512dd5e3f7624a6dfd945b761344 (diff)
downloadaur-b59853f7e19639c51fb9c564a63a004f488dfa30.tar.gz
patch to disable jack support https://github.com/digego/extempore/issues/403
-rw-r--r--PKGBUILD17
-rw-r--r--disable_jack.patch19
2 files changed, 31 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 720c03261a42..cf8e522a0a42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Abdó Roig-Maranges <abdo.roig@gmail.com>
pkgname=extempore-git
-pkgver=0.8.7.r35.g78c44413
-pkgrel=2
+pkgver=v0.8.9.r0.g0368489b
+pkgrel=1
pkgdesc="A cyber-physical programming environment for live coding"
arch=('i686' 'x86_64')
url="http://extempore.moso.com.au"
@@ -19,16 +19,23 @@ pkgver() {
git --git-dir="${srcdir}/extempore/.git" describe --long --tags | sed 's/^v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
+ # I was unable to compile portaudio with jack backend
+ cd "${srcdir}/extempore"
+ patch -p0 < ../../disable_jack.patch
+}
+
+build() {
mkdir -p "${srcdir}/build"
cd "${srcdir}/build"
# NOTE: set ASSETS to OFF you you don't want to download ~500MB of assets
+ # NOTE: building with debug symbols for easy reporting of bugs
cmake -DCMAKE_INSTALL_PREFIX=/opt/${pkgname} \
- -DJACK=ON \
-DBUILD_DEPS=ON \
-DPACKAGE=ON \
- -DASSETS=ON \
+ -DJACK=OFF \
+ -DCMAKE_BUILD_TYPE=Debug \
../extempore
make
diff --git a/disable_jack.patch b/disable_jack.patch
new file mode 100644
index 000000000000..b22f15d76a6d
--- /dev/null
+++ b/disable_jack.patch
@@ -0,0 +1,19 @@
+--- CMakeLists.txt 2021-05-22 11:30:27.958294663 +0200
++++ CMakeLists.txt.new 2021-05-22 11:29:17.120943327 +0200
+@@ -14,6 +14,8 @@
+
+ option(EXT_DYLIB "build extempore as a dynamic library" OFF)
+
++option(JACK "use the Jack Portaudio backend" ON)
++
+ ## this is useful because we can group targets together (e.g. all the AOT libs)
+ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+
+@@ -186,6 +188,7 @@
+ -DPA_BUILD_STATIC=ON
+ -DPA_BUILD_SHARED=OFF
+ -DPA_LIBNAME_ADD_SUFFIX=OFF
++ -DPA_USE_JACK=${JACK}
+ -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE}
+ -DCMAKE_C_FLAGS=${EXT_DEPS_C_FLAGS}
+ -DCMAKE_CXX_FLAGS=${EXT_DEPS_CXX_FLAGS}