summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyrton Santana2021-12-29 15:46:28 -0300
committerAyrton Santana2021-12-29 15:46:28 -0300
commitb5cba54bb4b4aaca24c2153f4dd97542d6b82fe7 (patch)
treee5a282e5365c8d98c47dce71b2676505d2aed75a
parentfeef2b758537da947a05cc9d8d78a9ca968182f8 (diff)
downloadaur-b5cba54bb4b4aaca24c2153f4dd97542d6b82fe7.tar.gz
upgpkg: arkade-bin 1:0.8.11-1
upstream release Update to version 0.8.11
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD13
3 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a481c80e4d6..91016f4e469f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arkade-bin
pkgdesc = Your one-stop CLI for Kubernetes. provides a simple CLI with strongly-typed flags to install charts and apps to your cluster in one command.
- pkgver = 0.6.15
+ pkgver = 0.8.11
pkgrel = 1
epoch = 1
url = https://github.com/alexellis/arkade/
@@ -20,8 +20,7 @@ pkgbase = arkade-bin
optdepends = aws-cli: cli for Amazon Web Services
optdepends = google-cloud-sdk: gcloud - command-line tools for the Google Cloud Platform
provides = arkade
- source = arkade-bin-0.6.15::https://github.com/alexellis/arkade/releases/download/0.6.15/arkade
- sha256sums = 2888a4d77dec2bca29dddcc6d24603183bf78479d363b89fb47a29fba21f8d0d
+ source = arkade-bin-0.8.11::https://github.com/alexellis/arkade/releases/download/0.8.11/arkade
+ sha256sums = 6eb47fa70180d79623accd24e92fc8de68c061fb9957a848c1e32abf91d4ad8b
pkgname = arkade-bin
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f9ecc0a87e76
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.tgz
+/*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 29f358af0fff..4cad297c32a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=arkade-bin
_pkgname=arkade
-pkgver=0.6.15
+pkgver=0.8.11
pkgrel=1
epoch=1
pkgdesc='Your one-stop CLI for Kubernetes. provides a simple CLI with strongly-typed flags to install charts and apps to your cluster in one command.'
@@ -25,7 +25,7 @@ provides=('arkade')
_OWNER=alexellis
case "${CARCH}" in
- x86_64) _CARCH='' && sha256sums=('2888a4d77dec2bca29dddcc6d24603183bf78479d363b89fb47a29fba21f8d0d');;
+ x86_64) _CARCH='' && sha256sums=('6eb47fa70180d79623accd24e92fc8de68c061fb9957a848c1e32abf91d4ad8b');;
aarch64) _CARCH='-arm64' && sha256sums=('SKIP');;
arm*) _CARCH='-armhf' && sha256sums=('SKIP');;
esac
@@ -33,17 +33,12 @@ esac
source=("$pkgname-$pkgver::https://github.com/${_OWNER}/${_pkgname}/releases/download/${pkgver}/${provides}${_CARCH}")
package() {
- #mkdir -p "${pkgdir}/opt"
- install -Dm 755 "$srcdir/$pkgname-$pkgver" "${pkgdir}/usr/local/bin/${provides}"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver" "${pkgdir}/usr/bin/${provides}"
- # mkdir -p "${pkgdir}/usr/local/bin"
- # ln -nfs /opt/${pkgname}/${provides} "${pkgdir}"/usr/local/bin/${provides}
-
- # Add command completion
# install -dm 755 "$pkgdir/usr/share/bash-completion/completions"
# install -dm 755 "$pkgdir/usr/share/zsh/site-functions"
# "$pkgdir/usr/bin/provides" completion bash > "$pkgdir/usr/share/bash-completion/completions/provides"
# "$pkgdir/usr/bin/provides" completion zsh > "$pkgdir/usr/share/zsh/site-functions/_provides"
}
-# vim:set ts=2 sw=2 et: \ No newline at end of file
+# vim:set ts=2 sw=2 et: