summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2018-09-21 13:53:50 +0200
committerhashworks2018-09-21 13:53:50 +0200
commitb5d889b233ef7a405bb04ab4b01f1d9cfa2f95fa (patch)
tree427bd94f7c1cdfb66a464a711a7f41a3afb116b5
parent6e8d90c53e17d12b851c4de2dd271605dc6fe1fd (diff)
downloadaur-b5d889b233ef7a405bb04ab4b01f1d9cfa2f95fa.tar.gz
Add openssl, move make to build function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dd471bdc558..6e3719879760 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = goaccess-git
pkgdesc = GoAccess is a real-time web log analyzer and interactive viewer that runs in a terminal in *nix systems or through your browser.
pkgver = r2768.2789816
- pkgrel = 2
+ pkgrel = 6
url = https://goaccess.io
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 89d1a5aafe40..c69e46120fd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: hashworks <mail@hashworks.net>
pkgname=goaccess-git
-pkgrel=2
+pkgrel=7
pkgver=r2768.2789816
pkgdesc='GoAccess is a real-time web log analyzer and interactive viewer that runs in a terminal in *nix systems or through your browser.'
url='https://goaccess.io'
@@ -9,7 +9,7 @@ license=('MIT')
arch=('any')
conflicts=('goaccess')
provides=('goaccess')
-depends=('ncurses')
+depends=('ncurses' 'libmaxminddb' 'openssl')
optdepends=('geoip: Provides a mmdb geoip database')
backup=('etc/goaccess.conf')
source=('git+https://github.com/allinurl/goaccess.git')
@@ -20,10 +20,14 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package() {
+build() {
cd "goaccess"
autoreconf -fiv
- ./configure --prefix="$pkgdir/usr" --enable-utf8 --enable-geoip=mmdb
- make
- make sysconfdir="$pkgdir/etc" install
+ ./configure --enable-utf8 --enable-geoip=mmdb --with-openssl
+ make prefix=/usr sysconfdir=/etc
+}
+
+package() {
+ cd "goaccess"
+ make prefix="$pkgdir/usr" sysconfdir="$pkgdir/etc" install
}