summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2022-10-10 09:55:17 +1000
committerMark Blakeney2022-10-10 09:55:17 +1000
commitb5fb08fcb2012a30ae7d7a6d529cbb123903dc32 (patch)
tree68b979739f43291d22d52c43829e36bbbd7f10f5
parent8e500cef7af5fbdc1afd6ae8032f93d1c2db2d9e (diff)
downloadaur-b5fb08fcb2012a30ae7d7a6d529cbb123903dc32.tar.gz
Simplify PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD33
2 files changed, 12 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38edf5085a9e..dc12f063bfaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,9 @@ pkgbase = vim-plugins-profiler
url = https://github.com/bulletmark/vim-plugins-profiler
arch = any
license = GPL3
- makedepends = python-pip
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-wheel
depends = python>=3.5
source = vim-plugins-profiler-1.14.tar.gz::https://github.com/bulletmark/vim-plugins-profiler/archive/1.14.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 0bd4b9cf333f..43dac4220360 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,21 @@ pkgver=1.14
pkgrel=1
pkgdesc="Utility to output a sorted list of VIM plugin startup times in millisec."
url="https://github.com/bulletmark/$pkgname"
-license=("GPL3")
-arch=("any")
+license=(GPL3)
+arch=(any)
depends=("python>=3.5")
-makedepends=("python-pip" "python-wheel")
+makedepends=(python-setuptools python-build python-installer python-wheel)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
md5sums=('54d6ed6683497390bceca36f02030751')
-package() {
+build() {
cd "$srcdir/$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
- PIP_CONFIG_FILE=/dev/null pip install \
- --root="$pkgdir" \
- --isolated \
- --ignore-installed \
- --no-deps \
- --disable-pip-version-check \
- --no-python-version-warning \
- --no-warn-script-location \
- --no-cache-dir \
- --no-compile \
- --progress-bar=off \
- --root-user-action=ignore \
- .
-
- local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
- local _pkgname="${pkgname//-/_}"
- cd "$pkgdir/$pdir"
- rm -f $_pkgname-*.dist-info/direct_url.json
- sed -i "/\/direct_url.json,/d" $_pkgname-*.dist-info/RECORD
- python -O -m compileall -q .
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 et: