summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabelian4242024-01-07 14:00:42 +0600
committerabelian4242024-01-07 14:00:42 +0600
commitb63845b339f0dd0993bf21c67bf0bfd0629264d1 (patch)
tree88a101fda98d990e9a091d6322850d64cdc2366f
parentf1089fda984d93a0fe59ad22a6edebede516c27f (diff)
downloadaur-b63845b339f0dd0993bf21c67bf0bfd0629264d1.tar.gz
Updated to build correctly against -git versions of kde-unstable packages
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD31
2 files changed, 41 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2fe560b8cd0..eb8468e0ff0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,42 @@
pkgbase = kwinft-git
pkgdesc = drop-in replacement for KWin with additional libwayland wrapping Qt/C++ library Wrapland
- pkgver = 5.27.0.beta.0.r764.gd913702e3
+ pkgver = 5.27.9
pkgrel = 1
url = https://gitlab.com/kwinft/kwinft
install = kwinft.install
arch = x86_64
license = LGPL
makedepends = git
- makedepends = extra-cmake-modules>=5.240.0
makedepends = qt6-tools
makedepends = kdoctools
+ makedepends = extra-cmake-modules-git
depends = python
depends = xcb-util-cursor
- depends = plasma-framework
- depends = kcmutils
- depends = kio
- depends = breeze
- depends = kinit
depends = qt6-sensors
- depends = wrapland
- depends = disman
- depends = kscreen
- depends = kscreenlocker
- depends = pipewire
- depends = libqaccessibilityclient-qt6
- depends = xorg-xwayland
- depends = kdeclarative
+ depends = wrapland-git
+ depends = disman-git
+ depends = kdisplay-git
depends = wlroots
+ depends = xorg-xwayland
+ depends = qt6-multimedia
+ depends = pipewire
+ depends = microsoft-gsl
+ depends = knewstuff-git
+ depends = kdecoration-git
+ depends = kcmutils-git
+ depends = kio-git
+ depends = kdeclarative-git
+ depends = kscreenlocker-git
optdepends = qt6-virtualkeyboard: virtual keyboard support for kwin-wayland
- provides = kwin=5.27.0.beta.0.r764.gd913702e3
- provides = kwinft=5.27.0.beta.0.r764.gd913702e3
+ optdepends = libplasma: plasma-framework6
+ optdepends = breeze>=5.80.0
+ optdepends = libqaccessibilityclient-qt6
+ optdepends = libkscreen-git: needed if kscreenlocker-git is used
+ provides = kwin=5.27.9
+ provides = kwinft=5.27.9
conflicts = kwin
conflicts = kwinft
- source = kwin::git+https://gitlab.com/kwinft/kwinft.git
+ source = git+https://gitlab.com/kwinft/kwinft.git
sha256sums = SKIP
pkgname = kwinft-git
diff --git a/PKGBUILD b/PKGBUILD
index 9644d40f1006..1e5508f96498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,30 @@
_pkgname=kwin
pkgname=kwinft-git
-pkgver=5.27.0.beta.0.r764.gd913702e3
+pkgver=5.27.9
pkgrel=1
pkgdesc='drop-in replacement for KWin with additional libwayland wrapping Qt/C++ library Wrapland'
arch=(x86_64)
url="https://gitlab.com/kwinft/kwinft"
license=(LGPL)
-depends=(python xcb-util-cursor plasma-framework kcmutils kio breeze kinit qt6-sensors wrapland disman kscreen kscreenlocker pipewire libqaccessibilityclient-qt6 xorg-xwayland kdeclarative wlroots)
-makedepends=(git 'extra-cmake-modules>=5.240.0' qt6-tools kdoctools)
-optdepends=('qt6-virtualkeyboard: virtual keyboard support for kwin-wayland')
+depends=(python xcb-util-cursor qt6-sensors wrapland-git disman-git kdisplay-git wlroots \
+ xorg-xwayland qt6-multimedia pipewire microsoft-gsl \
+ knewstuff-git kdecoration-git kcmutils-git kio-git kdeclarative-git kscreenlocker-git)
+makedepends=(git qt6-tools kdoctools extra-cmake-modules-git)
+optdepends=('qt6-virtualkeyboard: virtual keyboard support for kwin-wayland' \
+ 'libplasma: plasma-framework6' \
+ 'breeze>=5.80.0' \
+ 'libqaccessibilityclient-qt6' \
+ 'libkscreen-git: needed if kscreenlocker-git is used' )
provides=("$_pkgname=${pkgver}" "kwinft=${pkgver}")
conflicts=("$_pkgname" "kwinft")
-source=("$_pkgname::git+https://gitlab.com/kwinft/kwinft.git")
-sha256sums=('SKIP')
+source=("git+https://gitlab.com/kwinft/kwinft.git")
+sha256sum=
install=kwinft.install
pkgver() {
- cd "$_pkgname"
- git describe --long --tags | sed 's/^kwinft\@//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname/-git}"
+ git describe --long | sed 's/^kwinft\@//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -31,10 +37,10 @@ prepare() {
build() {
cd "$srcdir"/build
- cmake "$srcdir"/$_pkgname \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ cmake "$srcdir"/${pkgname/-git} \
+ -DQT_MAJOR_VERSION=6 \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF
make
}
@@ -43,3 +49,4 @@ package() {
cd "$srcdir"/build
make DESTDIR="$pkgdir" install
}
+sha256sums=('SKIP')