summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitb64a4be84f9b7c00cec99cb738f05a0386e876b5 (patch)
tree5a83939c47f15975ce8e8edd00f3f21da86ae6a8
downloadaur-b64a4be84f9b7c00cec99cb738f05a0386e876b5.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD76
-rw-r--r--Wings4
-rw-r--r--Wings644
-rw-r--r--wings2.desktop13
-rw-r--r--wings2.install5
6 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e4f64c82cbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = wings2
+ pkgdesc = Fly small and agile ships in varied maps.
+ pkgver = 1.3.6
+ pkgrel = 1
+ url = http://www.wings2.net/
+ install = wings2.install
+ arch = i686
+ arch = x86_64
+ license = custom: "Wings 2 License"
+ depends = sdl
+ depends = sdl_image
+ depends = sdl_net
+ depends = sdl_mixer
+ depends = libgl
+ depends = libstdc++5
+ depends = desktop-file-utils
+ optdepends = wings2-levelpack: for more levels in the game
+ optdepends = wings2-musicpack: more game music
+ options = !strip
+ options = docs
+ source = wings2_v1.3.6_linux.tar.gz::http://www.wings2.net/util/download.php?file=wings2_v1.3.6_linux.tar.gz
+ source = wings2.desktop
+ source = Wings
+ source = Wings64
+ md5sums = 4adb5b270a410225c240da0c9a429018
+ md5sums = 6958819bc2ba835e355a5ae38f10e663
+ md5sums = e0118af926a36776aaa7b79853486373
+ md5sums = bc7e663ba893172400285e36ffc19fb4
+
+pkgname = wings2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fd953816b7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=wings2
+pkgver=1.3.6
+pkgrel=1
+pkgdesc="Fly small and agile ships in varied maps."
+arch=('i686' 'x86_64')
+url="http://www.wings2.net/"
+license=('custom: "Wings 2 License"')
+depends=('sdl' 'sdl_image' 'sdl_net' 'sdl_mixer' 'libgl' 'libstdc++5' 'desktop-file-utils')
+optdepends=('wings2-levelpack: for more levels in the game'
+ 'wings2-musicpack: more game music')
+options=('!strip' 'docs')
+install=$pkgname.install
+source=(${pkgname}_v${pkgver}_linux.tar.gz::http://www.wings2.net/util/download.php?file=${pkgname}_v${pkgver}_linux.tar.gz \
+ $pkgname.desktop \
+ Wings \
+ Wings64)
+
+md5sums=('4adb5b270a410225c240da0c9a429018'
+ '6958819bc2ba835e355a5ae38f10e663'
+ 'e0118af926a36776aaa7b79853486373'
+ 'bc7e663ba893172400285e36ffc19fb4')
+
+build() {
+ cd "${srcdir}"
+
+ install -d "${pkgdir}/opt/Wings2" "${pkgdir}/usr/bin" "${pkgdir}/usr/share/licenses/wings2" || return 1
+ cp -r "${srcdir}/Wings2" "${pkgdir}/opt/" || return 1
+ find ${pkgdir}/opt -type d -exec chmod 755 "{}" \; || return 1
+ find ${pkgdir}/opt -type f -exec chmod 644 "{}" \; || return 1
+
+#config.xml and stdout.txt files must be writable by all
+ touch ${pkgdir}/opt/Wings2/bin/{config.xml,stdout.txt} || return 1
+ chmod a+w ${pkgdir}/opt/Wings2/bin/{config.xml,stdout.txt} || return 1
+
+#directory for received levels from server writable
+ chmod a+w "${pkgdir}/opt/Wings2/levels/received" || return 1
+
+#.desktop file
+ install -D -m644 "${srcdir}/wings2.desktop" "${pkgdir}/usr/share/applications/wings2.desktop" || return 1
+
+#license
+ install -D -m644 "${pkgdir}/opt/Wings2/doc/License.txt" "${pkgdir}/usr/share/licenses/wings2/LICENSE" || return 1
+
+#remove playlist
+ rm "${pkgdir}/opt/Wings2/music/menu_music.txt" || return 1
+
+
+# ---------------------- i686 architecture ----------------------
+if [ "$CARCH" = "i686" ]; then
+
+#install run file for i686
+ install -D -m755 "${srcdir}/Wings" "${pkgdir}/usr/bin/Wings" || return 1
+
+#making files for i686 executable
+ chmod 775 "${pkgdir}/opt/Wings2/bin/Wings" "${pkgdir}/opt/Wings2/bin/Makelev" || return 1
+
+#remove binaries for x86_64
+ rm "${pkgdir}"/opt/Wings2/bin/{Wings64,Makelev64} || return 1
+
+
+# ---------------------- x86_64 architecture ----------------------
+elif [ "$CARCH" = "x86_64" ]; then
+
+#install run file for x86_64
+ install -D -m755 "${srcdir}/Wings64" "${pkgdir}/usr/bin/Wings" || return 1
+
+#making files for x86_64 executable
+ chmod 775 "${pkgdir}/opt/Wings2/bin/Wings64" "${pkgdir}/opt/Wings2/bin/Makelev64" || return 1
+
+#remove i686 binaries
+ rm "${pkgdir}"/opt/Wings2/bin/{Wings,Makelev} || return 1
+
+fi
+}
diff --git a/Wings b/Wings
new file mode 100644
index 000000000000..49a44674cac2
--- /dev/null
+++ b/Wings
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /opt/Wings2/bin
+exec ./Wings $@ \ No newline at end of file
diff --git a/Wings64 b/Wings64
new file mode 100644
index 000000000000..82176c74db45
--- /dev/null
+++ b/Wings64
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /opt/Wings2/bin
+exec ./Wings64 $@ \ No newline at end of file
diff --git a/wings2.desktop b/wings2.desktop
new file mode 100644
index 000000000000..449904bcebab
--- /dev/null
+++ b/wings2.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Type=Application
+Name=Wings2
+GenericName=Wings2
+Comment=Fly small and agile ships in varied maps
+Comment[cs]=Poraž protivníky v bitvě malých vesmírných lodí
+Comment[pl]=Stań się pilotem małego i zwinnego pojazdu
+Icon=/opt/Wings2/graphics/icon.png
+Exec=Wings
+StartupNotify=true
+Terminal=false
+MimeType=application/x-executable;
+Categories=Game;
diff --git a/wings2.install b/wings2.install
new file mode 100644
index 000000000000..d12ffab08d2a
--- /dev/null
+++ b/wings2.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo -n "Updating desktop and mime database ..."
+ update-desktop-database -q
+ echo "done."
+}