summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2018-10-01 16:35:11 +0200
committeranthraxx2018-10-01 16:35:11 +0200
commitb67811391582fc05e298e66860dd75265e3193d1 (patch)
tree15662261374647bc3746b71b082aa3e4eeb716e0
downloadaur-b67811391582fc05e298e66860dd75265e3193d1.tar.gz
addpkg: pgadmin3 1.22.2-6
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD53
-rw-r--r--pgadmin3-fix-segfault.patch11
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7682b717a65b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = pgadmin3
+ pkgdesc = Comprehensive design and management interface for PostgreSQL
+ pkgver = 1.22.2
+ pkgrel = 6
+ url = http://www.pgadmin.org
+ arch = x86_64
+ license = custom
+ makedepends = libpqxx
+ makedepends = krb5
+ makedepends = postgresql
+ makedepends = imagemagick
+ depends = wxgtk2
+ depends = postgresql-libs
+ depends = libxslt
+ depends = libgcrypt
+ source = https://ftp.postgresql.org/pub/pgadmin/pgadmin3/v1.22.2/src/pgadmin3-1.22.2.tar.gz
+ source = https://ftp.postgresql.org/pub/pgadmin/pgadmin3/v1.22.2/src/pgadmin3-1.22.2.tar.gz.sig
+ source = pgadmin3-fix-segfault.patch
+ validpgpkeys = E0C4CEEB826B1FDA4FB468E024ADFAAF698F1519
+ sha256sums = 9b68b0e3d3f0a261344fb8196825967d1e7acaca1d8cc82c42e12368ca5844ac
+ sha256sums = SKIP
+ sha256sums = b175869b77bcbfa43f1bc256277966882789883792c4f9dd26038ec248def6a2
+
+pkgname = pgadmin3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27db942aeb9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+# Contributor: Benjamin Andresen <benny@klapmuetz.org>
+# Contributor: bekks <eduard.warkentin@gmx.de>
+
+pkgname=pgadmin3
+pkgver=1.22.2
+pkgrel=6
+pkgdesc="Comprehensive design and management interface for PostgreSQL"
+arch=('x86_64')
+url="http://www.pgadmin.org"
+license=('custom')
+# Dependency wxgtk3 is not supported due to segmentation fault (FS#54676)
+depends=('wxgtk2' 'postgresql-libs' 'libxslt' 'libgcrypt')
+makedepends=('libpqxx' 'krb5' 'postgresql' 'imagemagick')
+validpgpkeys=('E0C4CEEB826B1FDA4FB468E024ADFAAF698F1519')
+source=(https://ftp.postgresql.org/pub/pgadmin/pgadmin3/v${pkgver}/src/pgadmin3-${pkgver}.tar.gz{,.sig}
+ pgadmin3-fix-segfault.patch)
+sha256sums=('9b68b0e3d3f0a261344fb8196825967d1e7acaca1d8cc82c42e12368ca5844ac'
+ 'SKIP'
+ 'b175869b77bcbfa43f1bc256277966882789883792c4f9dd26038ec248def6a2')
+
+prepare() {
+ cd "$srcdir"
+ convert pgadmin3-${pkgver}/pgadmin/include/images/pgAdmin3.ico pgAdmin3.png
+
+# Fix segfault at startup (Debian)
+ cd $pkgname-$pkgver
+ patch -p1 -i ../pgadmin3-fix-segfault.patch
+}
+
+build() {
+ cd "$srcdir"/pgadmin3-${pkgver}
+ ./configure --prefix=/usr --with-wx-version=3.0 --with-libgcrypt
+ make
+}
+
+package() {
+ cd "$srcdir"/pgadmin3-${pkgver}
+
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 i18n/$pkgname.lng "$pkgdir/usr/share/pgadmin3/i18n"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm644 pgadmin/include/images/pgAdmin3.ico "$pkgdir/usr/share/pgadmin3/pgAdmin3.ico"
+ install -Dm644 "$srcdir/pgAdmin3-1.png" "$pkgdir/usr/share/pgadmin3/pgAdmin3.png"
+
+ install -Dm644 "$srcdir/pgAdmin3-3.png" "$pkgdir/usr/share/icons/hicolor/16x16/apps/pgAdmin3.png"
+ install -Dm644 "$srcdir/pgAdmin3-2.png" "$pkgdir/usr/share/icons/hicolor/32x32/apps/pgAdmin3.png"
+ install -Dm644 "$srcdir/pgAdmin3-1.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/pgAdmin3.png"
+
+ install -Dm644 "pkg/pgadmin3.desktop" "$pkgdir/usr/share/applications/pgadmin3.desktop"
+}
diff --git a/pgadmin3-fix-segfault.patch b/pgadmin3-fix-segfault.patch
new file mode 100644
index 000000000000..1396f8de8aab
--- /dev/null
+++ b/pgadmin3-fix-segfault.patch
@@ -0,0 +1,11 @@
+--- a/pgadmin/frm/plugins.cpp
++++ b/pgadmin/frm/plugins.cpp
+@@ -380,7 +380,7 @@ bool pluginUtilityFactory::CheckEnable(p
+ {
+ // If we need a specific server type, we can't enable unless
+ // we have a connection.
+- if (!obj || !(obj->GetConnection()->GetStatus() == PGCONN_OK))
++ if (!obj || !obj->GetConnection() || !(obj->GetConnection()->GetStatus() == PGCONN_OK))
+ return false;
+
+ // Get the server type.