summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2024-04-14 22:20:00 +0200
committerSimon Brulhart2024-04-14 22:20:00 +0200
commitb682e469ef41e423ef4bb0666fd80b9225ccebb1 (patch)
tree9bdec37e6f7228975a5f570051886eb650c72e6e
parent6d29e9b997d134854b021d4e989c95d34a243f58 (diff)
downloadaur-b682e469ef41e423ef4bb0666fd80b9225ccebb1.tar.gz
Fix policy to disable auto-update
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--policies.json2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b45fe032629e..d5b0e1acf3cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-beta-bin
pkgdesc = Standalone web browser from mozilla.org - Beta
pkgver = 125.0rc1
- pkgrel = 1
+ pkgrel = 2
url = https://www.mozilla.org/en-US/firefox/channel/#beta
install = firefox-beta-bin.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index fa05635e1a29..36ee4bfe7a4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=firefox-beta
pkgver=125.0rc1
_major=${pkgver/rc*}
_build=${pkgver/*rc}
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org - Beta"
arch=('x86_64')
url="https://www.mozilla.org/en-US/firefox/channel/#beta"
@@ -29,7 +29,7 @@ source=("https://archive.mozilla.org/pub/firefox/releases/$pkgver/linux-x86_64/e
sha256sums=('3108abece953442b52d3da2716388a779ebb79b0936877c7c0826593f6fce7a6'
'4bec62032e49c28ff27750abddbdbdbb1a4b5cba719c39498968fe53adee790b'
'210f13ea47c4b96387f26ee7fc4dfc5c192cfb169aef2a13303fbd1ee58b3761'
- '2d7e8d947c392142dba0c80a7e5ecfdf14f7783e24885ab417d4224574b8c4f8')
+ 'e977c3d690224dd727d8761d2c0a66ba41bfd02ae0fd7850c4545d06b5a8e63c')
# RC
if [[ $_build = ? ]]; then
source[0]="firefox-$pkgver.tar.bz2::https://ftp.mozilla.org/pub/firefox/candidates/$_major-candidates/build$_build/linux-x86_64/en-US/firefox-$_major.tar.bz2"
@@ -45,7 +45,7 @@ package() {
msg2 "Moving stuff in place..."
# Install
cp -r firefox/ "$pkgdir"/opt/$_pkgname
- install -m644 policies.json -D -t "$pkgdir"/opt/$_pkgname/policies/
+ install -m644 policies.json -D -t "$pkgdir"/opt/$_pkgname/distribution/
# Launchers
install -m755 $_pkgname.sh "$pkgdir"/usr/bin/$_pkgname
diff --git a/policies.json b/policies.json
index 1f4d0f25bb85..f36622021fcd 100644
--- a/policies.json
+++ b/policies.json
@@ -1,5 +1,5 @@
{
"policies": {
- "AppAutoUpdate": false
+ "DisableAppUpdate": true
}
}