summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarsten Pufahl2023-10-02 14:09:48 +0200
committerKarsten Pufahl2023-10-02 14:09:48 +0200
commitb699d81daef99f10b0a12e20ed959b6b26c849b2 (patch)
treef32eea77620e40d8ee70af4899ad081eb8d5af49
parent7dba3c962c285a40a2d938e881dabad3ac9211e4 (diff)
downloadaur-b699d81daef99f10b0a12e20ed959b6b26c849b2.tar.gz
version 6.9.2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
-rw-r--r--stm32cubemx.sh2
3 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecaaa474ee27..84f4982d5445 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = stm32cubemx
pkgdesc = graphical software configuration tool for STM32 microcontrollers that allows generating C initialization code
- pkgver = 6.9.1
+ pkgver = 6.9.2
pkgrel = 1
url = https://www.st.com/en/development-tools/stm32cubemx.html
arch = any
license = custom
makedepends = imagemagick
depends = java-runtime>=17
- depends = java-runtime<21
- depends = archlinux-java-run
+ depends = archlinux-java-run>=10
depends = bash
options = !strip
- source = https://sw-center.st.com/packs/resource/library/stm32cube_mx_v691-lin.zip
+ source = https://sw-center.st.com/packs/resource/library/stm32cube_mx_v692-lin.zip
source = stm32cubemx.desktop
source = stm32cubemx.sh
- sha512sums = 8545425ba395b643ff89a7e7ff5d9c57836696a3d0fc4cfe3d6761567d914d0db772afb249aee3226a2e7b9eab942e026615173968edf2ab2a4996453a3da0b7
+ sha512sums = b833843e999a26a250e9b908e125911f2271494a9fac708c4d02c374426c7d50efd79a9522af7025751da549e00bdc5d07735b45f97f03fe5c19beb96a0ae318
sha512sums = 83c67bef3e8f8434903fe0c067442cc7473459386fdcb0225af1b3a75fd75e2be393f91f877c8410f1055ca4ec531b2df707fcab10663cae382a7f4066c8548b
- sha512sums = 8c46e1396e629733d4a692305e877a5b340b4a00ecc7add7e98973c7f216fa3f7128d7c23a9d37a832ac928a3b778d26ebfb0df9b9b49112b74e1dafe827ee98
+ sha512sums = d0dfbf096d7d147f59ed9fc888e612636e6d025688f2ef82d528110da977e20175087eeb24bb398053ce0cb4e530dd0b4f0bd48574c028879ceffa44a04029c1
pkgname = stm32cubemx
diff --git a/PKGBUILD b/PKGBUILD
index 33d2828447b2..f4811d788c42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: laserK <echo 'Y29udGFjdEBrYXJzdGVucHVmYWhsLmRlCg==' | base64 -d>
pkgname=stm32cubemx
-pkgver=6.9.1
+pkgver=6.9.2
pkgrel=1
epoch=
pkgdesc="graphical software configuration tool for STM32 microcontrollers that allows generating C initialization code"
@@ -9,8 +9,7 @@ url="https://www.st.com/en/development-tools/stm32cubemx.html"
license=('custom')
groups=()
depends=('java-runtime>=17'
- 'java-runtime<21'
- 'archlinux-java-run'
+ 'archlinux-java-run>=10'
'bash')
makedepends=('imagemagick')
checkdepends=()
@@ -26,9 +25,9 @@ source=("https://sw-center.st.com/packs/resource/library/stm32cube_mx_v${pkgver/
"stm32cubemx.desktop"
"stm32cubemx.sh")
noextract=()
-sha512sums=('8545425ba395b643ff89a7e7ff5d9c57836696a3d0fc4cfe3d6761567d914d0db772afb249aee3226a2e7b9eab942e026615173968edf2ab2a4996453a3da0b7'
+sha512sums=('b833843e999a26a250e9b908e125911f2271494a9fac708c4d02c374426c7d50efd79a9522af7025751da549e00bdc5d07735b45f97f03fe5c19beb96a0ae318'
'83c67bef3e8f8434903fe0c067442cc7473459386fdcb0225af1b3a75fd75e2be393f91f877c8410f1055ca4ec531b2df707fcab10663cae382a7f4066c8548b'
- '8c46e1396e629733d4a692305e877a5b340b4a00ecc7add7e98973c7f216fa3f7128d7c23a9d37a832ac928a3b778d26ebfb0df9b9b49112b74e1dafe827ee98')
+ 'd0dfbf096d7d147f59ed9fc888e612636e6d025688f2ef82d528110da977e20175087eeb24bb398053ce0cb4e530dd0b4f0bd48574c028879ceffa44a04029c1')
validpgpkeys=()
package() {
diff --git a/stm32cubemx.sh b/stm32cubemx.sh
index cd1d5f5d0cf9..b9dab29fe9fa 100644
--- a/stm32cubemx.sh
+++ b/stm32cubemx.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec archlinux-java-run --min 17 --max 20 -- -jar /opt/stm32cubemx/STM32CubeMX "$@"
+exec archlinux-java-run --min 17 -- -jar /opt/stm32cubemx/STM32CubeMX "$@"