summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphiresky2017-04-03 02:29:34 +0200
committerphiresky2017-04-03 02:29:34 +0200
commitb6c9d206af9ac4ec56ad15fd9b78ab5e6c6f92a5 (patch)
treecbc45d1d2e7e74a5f83ed69087b19ed96fb12bc0
parentabc87fde63d0e3560ef837021ea716339ef68938 (diff)
downloadaur-b6c9d206af9ac4ec56ad15fd9b78ab5e6c6f92a5.tar.gz
update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
-rw-r--r--reddit-placebot.install9
3 files changed, 26 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b431253153d..df215185ffda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
# Generated by mksrcinfo v8
-# Mon Apr 3 00:20:44 UTC 2017
+# Mon Apr 3 00:29:30 UTC 2017
pkgbase = reddit-placebot
pkgdesc = Automatically place pixels on reddit.com/r/place (not working yet, needs patches)
- pkgver = r18.c8fcbfb
- pkgrel = 1
+ pkgver = r20.3a171c3
+ pkgrel = 2
url = https://github.com/wijagels/reddit-placebot
install = reddit-placebot.install
arch = any
- license = GPL3
+ license = MIT
makedepends = git
makedepends = npm
depends = nodejs
provides = reddit-placebot-git
conflicts = reddit-placebot-git
+ source = git+https://github.com/wijagels/reddit-placebot
+ source = reddit-placebot.service
+ source = reddit-placebot.install
+ sha256sums = SKIP
+ sha256sums = 7bff9b9bab1fa52e9919f3f258588375ad4369cdc0fb6cf2f738a01f957ab082
+ sha256sums = 5a395a992339b1d346be48ab0ef021ff80d68ef24f9db8931aec1aebbf4150f5
pkgname = reddit-placebot
diff --git a/PKGBUILD b/PKGBUILD
index 8d797a5003ee..286eb9cd7588 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: phiresky <phireskyde+git@gmail.com>
pkgname=reddit-placebot
-pkgver=r18.c8fcbfb
-pkgrel=1
+pkgver=r20.3a171c3
+pkgrel=2
pkgdesc="Automatically place pixels on reddit.com/r/place (not working yet, needs patches)"
arch=(any)
url="https://github.com/wijagels/reddit-placebot"
-license=('GPL3')
+license=('MIT')
groups=()
depends=(nodejs)
makedepends=('git' npm)
@@ -15,12 +15,14 @@ replaces=()
backup=()
options=()
install=reddit-placebot.install
-sources=(
+source=(
'git+https://github.com/wijagels/reddit-placebot'
'reddit-placebot.service'
'reddit-placebot.install'
)
-
+sha256sums=('SKIP'
+ '7bff9b9bab1fa52e9919f3f258588375ad4369cdc0fb6cf2f738a01f957ab082'
+ '5a395a992339b1d346be48ab0ef021ff80d68ef24f9db8931aec1aebbf4150f5')
noextract=()
diff --git a/reddit-placebot.install b/reddit-placebot.install
index b261d097dddd..67bf0b0c317c 100644
--- a/reddit-placebot.install
+++ b/reddit-placebot.install
@@ -1,5 +1,10 @@
post_install() {
cat <<EOF
+1. Copy the config file to ~/.config:
+
+ mkdir ~/.config/reddit-placebot
+ cp /usr/lib/node_modules/reddit-placebot/config.js ~/.config/reddit-placebot
+
Create a file users.json in ~/.config/reddit-placebot/users.json as follows:
{
@@ -18,3 +23,7 @@ and monitor the output using
EOF
}
+
+post_upgrade() {
+ post_install
+}