summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Latifi2021-12-07 01:58:23 +0100
committerFlorian Latifi2021-12-07 01:58:23 +0100
commitb6e70fd2368736ad4b8ef0f98a67cf5953332b2b (patch)
treea64a6469c67319f7ffaa2d90c637c716decb6906
parent46c05a2069599365633b9a372fa02bd48056d914 (diff)
downloadaur-b6e70fd2368736ad4b8ef0f98a67cf5953332b2b.tar.gz
Update to 2.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
-rw-r--r--use-format-string.patch21
3 files changed, 46 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53243e7febd9..2b380773ad69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = evolution-decsync
- pkgdesc = DecSync Plugin for Evolution. It syncs contact and calendars to a directory, which can be shared with syncthing or rsync
- pkgver = 1.3.0
- pkgrel = 2
+ pkgdesc = An Evolution plugin which synchronizes contacts and calendars using DecSync.
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/39aldo39/Evolution-DecSync
arch = x86_64
arch = i686
@@ -14,8 +14,9 @@ pkgbase = evolution-decsync
depends = evolution-data-server
depends = evolution
depends = libdecsync
- source = evolution-decsync-1.3.0.tar.gz::https://github.com/39aldo39/Evolution-DecSync/archive/v1.3.0.tar.gz
- sha256sums = 98defcfd8af9b7a3248e7f2b674975b83e66abee08e949a598815189ea83a4dc
+ source = https://github.com/39aldo39/Evolution-DecSync/archive/v2.0.0-evolution-3.40.tar.gz
+ source = use-format-string.patch
+ sha256sums = 8772a8fcaf07cffe15163cf4d0b598d2cb8806bea4ddaa9ddfe150771da1679b
+ sha256sums = 4c2e04a0e2352f22197db66f416670c0eb3da44f4520195e660e804b820388fc
pkgname = evolution-decsync
-
diff --git a/PKGBUILD b/PKGBUILD
index 41dbf7fa35ea..bd7b5b2c7a00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,35 @@
-# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
-# Contributor: Vasket <vasket at dismail dot de>
+# Contributor: Fabio Loli <fabio.loli@disroot.org>
+# Contributor: Vasket <vasket@dismail.de>
+# Contributor: Florian Latifi <mail@florian-latifi.at>
pkgname=evolution-decsync
-pkgver=1.3.0
-pkgrel=2
-pkgdesc="DecSync Plugin for Evolution. It syncs contact and calendars to a directory, which can be shared with syncthing or rsync"
+pkgver=2.0.0
+_pkgver=2.0.0-evolution-3.40
+pkgrel=1
+pkgdesc="An Evolution plugin which synchronizes contacts and calendars using DecSync."
arch=(x86_64 i686 armv7h aarch64)
license=(LGPL)
url="https://github.com/39aldo39/Evolution-DecSync"
depends=(json-c evolution-data-server evolution libdecsync)
makedepends=(meson ninja)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/39aldo39/Evolution-DecSync/archive/v${pkgver}.tar.gz")
-sha256sums=('98defcfd8af9b7a3248e7f2b674975b83e66abee08e949a598815189ea83a4dc')
+source=("https://github.com/39aldo39/Evolution-DecSync/archive/v${_pkgver}.tar.gz"
+ "use-format-string.patch")
+sha256sums=('8772a8fcaf07cffe15163cf4d0b598d2cb8806bea4ddaa9ddfe150771da1679b'
+ '4c2e04a0e2352f22197db66f416670c0eb3da44f4520195e660e804b820388fc')
+
+prepare() {
+ cd "Evolution-DecSync-${_pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/use-format-string.patch"
+}
build() {
- cd "Evolution-DecSync-${pkgver}"
+ cd "Evolution-DecSync-${_pkgver}"
meson build
ninja -C build
}
package() {
- cd "Evolution-DecSync-${pkgver}"
+ cd "Evolution-DecSync-${_pkgver}"
DESTDIR="${pkgdir}" meson install -C build
}
diff --git a/use-format-string.patch b/use-format-string.patch
new file mode 100644
index 000000000000..d7f1a9609d97
--- /dev/null
+++ b/use-format-string.patch
@@ -0,0 +1,21 @@
+From 0594a82b134aa133e6c60b1a88cea94063179e24 Mon Sep 17 00:00:00 2001
+From: Aldo Gunsing <dev@aldogunsing.nl>
+Date: Tue, 19 Oct 2021 21:05:09 +0200
+Subject: [PATCH] Use format string (#36)
+
+---
+ src/modules/utils/decsync.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/modules/utils/decsync.c b/src/modules/utils/decsync.c
+index 40c538e..755aeaf 100644
+--- a/src/modules/utils/decsync.c
++++ b/src/modules/utils/decsync.c
+@@ -175,6 +175,7 @@ config_decsync_update_combo_box (Context *context)
+ GTK_DIALOG_DESTROY_WITH_PARENT,
+ GTK_MESSAGE_WARNING,
+ GTK_BUTTONS_OK,
++ "%s",
+ error_string);
+ title = _("DecSync");
+ gtk_window_set_title (GTK_WINDOW (dialog), title);