summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2023-01-29 22:15:10 -0500
committerSlashbunny2023-01-29 22:15:10 -0500
commitb6f572014b6387b67b00544256d6047d9f225825 (patch)
tree769c60cf62785c682487295fcfd527840d022c09
parent76f84ae9f57493556c542d8897ef64ca8651cf56 (diff)
downloadaur-b6f572014b6387b67b00544256d6047d9f225825.tar.gz
Update to latest upstream version
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD12
-rw-r--r--gcc10.patch122
4 files changed, 13 insertions, 136 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15ff44074bf7..24c0ef8a58ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ezquake
pkgdesc = One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play.
- pkgver = 3.2.3
+ pkgver = 3.6.1
pkgrel = 1
url = https://www.ezquake.com/
install = ezquake.install
@@ -20,13 +20,13 @@ pkgbase = ezquake
provides = fuhquake
conflicts = ezquake-git
conflicts = fuhquake
- noextract = ezquake-ubuntu-full-3.2.3.tar.gz
- source = https://github.com/ezQuake/ezquake-source/archive/3.2.3.tar.gz
- source = https://github.com/ezQuake/ezquake-source/releases/download/3.2.3/ezquake-ubuntu-3.2.3-full.tar.gz
+ noextract = ezquake-ubuntu-3.2.3-full.tar.gz
+ source = https://github.com/QW-Group/ezquake-source/archive/refs/tags/3.6.1.zip
+ source = https://github.com/QW-Group/ezquake-source/releases/download/3.2.3/ezquake-ubuntu-3.2.3-full.tar.gz
source = ezquake.launcher
source = ezquake.desktop
source = ezquake.ico
- sha256sums = ec5187b47ad859cf459381296e8d1d560041fd90462dbe0ab89c65e320677ed4
+ sha256sums = 6a7ee1c09d74425915a777fa74fbb3b19a1897713e27b1e00b83772ece046743
sha256sums = d58f26ed912166615420f0d0b208a10fd2539a84b90e85edfcb1aedc94615af5
sha256sums = aa59da4a296a43af8ea8c5670cef5980a15407124b3e53f3cf805ceb6126e6ed
sha256sums = e92b9cdeac5eadced50a6167eb53b1343b0772d3bf8afa310eb281b88bf7e677
diff --git a/.gitignore b/.gitignore
index c463dbaf5e50..853e3b727602 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
src/
pkg/
-*.src.tar.gz
*.pkg.tar.zst
-ezquake-*full*.tar.gz
-3.2.*.tar.gz
+ezquake-ubuntu-*-full.tar.gz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index ae8bd7d8d7f2..89ca66380c88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
pkgname=ezquake
-pkgver=3.2.3
+pkgver=3.6.1
pkgrel=1
pkgdesc="One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play."
url="https://www.ezquake.com/"
@@ -12,11 +12,11 @@ conflicts=('ezquake-git' 'fuhquake')
provides=('quake' 'fuhquake')
arch=('x86_64')
install=ezquake.install
-source=("https://github.com/ezQuake/ezquake-source/archive/${pkgver}.tar.gz"
-"https://github.com/ezQuake/ezquake-source/releases/download/${pkgver}/ezquake-ubuntu-${pkgver}-full.tar.gz"
+source=("https://github.com/QW-Group/ezquake-source/archive/refs/tags/${pkgver}.zip"
+'https://github.com/QW-Group/ezquake-source/releases/download/3.2.3/ezquake-ubuntu-3.2.3-full.tar.gz'
'ezquake.launcher' 'ezquake.desktop' 'ezquake.ico')
-noextract=("ezquake-ubuntu-full-${pkgver}.tar.gz")
-sha256sums=('ec5187b47ad859cf459381296e8d1d560041fd90462dbe0ab89c65e320677ed4'
+noextract=("ezquake-ubuntu-3.2.3-full.tar.gz")
+sha256sums=('6a7ee1c09d74425915a777fa74fbb3b19a1897713e27b1e00b83772ece046743'
'd58f26ed912166615420f0d0b208a10fd2539a84b90e85edfcb1aedc94615af5'
'aa59da4a296a43af8ea8c5670cef5980a15407124b3e53f3cf805ceb6126e6ed'
'e92b9cdeac5eadced50a6167eb53b1343b0772d3bf8afa310eb281b88bf7e677'
@@ -36,7 +36,7 @@ package() {
install -d "${pkgdir}/opt/quake"
# Unpack ezQuake assets package (base)
- bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake-ubuntu-${pkgver}-full.tar.gz"
+ bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake-ubuntu-3.2.3-full.tar.gz"
# Clean up permissions in assets package
find "${pkgdir}/opt/quake" -type d -exec chmod 0755 "{}" \;
diff --git a/gcc10.patch b/gcc10.patch
deleted file mode 100644
index 20d5a007a9c4..000000000000
--- a/gcc10.patch
+++ /dev/null
@@ -1,122 +0,0 @@
---- a/cl_screen.c
-+++ b/cl_screen.c
-@@ -3370,9 +3370,9 @@ static char *Sshot_SshotDirectory(void) {
- }
-
- #ifdef X11_GAMMA_WORKAROUND
--unsigned short ramps[3][4096];
-+extern unsigned short ramps[3][4096];
- #else
--unsigned short ramps[3][256];
-+extern unsigned short ramps[3][256];
- #endif
-
- //applies hwgamma to RGB data
---- a/cl_tent.c
-+++ b/cl_tent.c
-@@ -29,6 +29,8 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- #include "utils.h"
- #include "qsound.h"
-
-+temp_entity_list_t temp_entities;
-+
- #define MAX_BEAMS 32
- typedef struct
- {
---- a/common_draw.c
-+++ b/common_draw.c
-@@ -26,6 +26,9 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
- #include "utils.h"
- #include "Ctrl.h"
-
-+// FIXME: this is horrible - points to &hud_gameclock_offset->integer
-+int* gameclockoffset;
-+
- #if 0
- void Draw_CenterString (int y, char *str)
- {
---- a/common_draw.h
-+++ b/common_draw.h
-@@ -92,7 +92,7 @@ void HUD_AfterDraw(void);
-
- qbool Draw_BigFontAvailable(void);
-
--int *gameclockoffset; // hud_gameclock time offset in seconds
-+extern int *gameclockoffset; // hud_gameclock time offset in seconds
-
- void SCR_DrawWadString(int x, int y, float scale, const char *t);
- void SCR_HUD_DrawBar(int direction, int value, float max_value, byte *color, int x, int y, int width, int height);
---- a/protocol.h
-+++ b/protocol.h
-@@ -465,5 +465,5 @@ typedef struct temp_entity_list_s
- int count;
- } temp_entity_list_t;
-
--temp_entity_list_t temp_entities;
-+extern temp_entity_list_t temp_entities;
-
---- a/vfs.h
-+++ b/vfs.h
-@@ -131,7 +131,7 @@ vfsfile_t *FS_OpenTCP(char *name);
- // GZIP (*.gz) Support
- //=====================
- #ifdef WITH_ZLIB
--searchpathfuncs_t gzipfilefuncs;
-+extern searchpathfuncs_t gzipfilefuncs;
- #endif // WITH_ZLIB
-
- //=====================
---- a/vx_stuff.c
-+++ b/vx_stuff.c
-@@ -27,6 +27,15 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
-
- int GL_LoadTextureImage (char * , char *, int, int, int);
- int coronatexture;
-+int gunflashtexture;
-+int explosionflashtexture1;
-+int explosionflashtexture2;
-+int explosionflashtexture3;
-+int explosionflashtexture4;
-+int explosionflashtexture5;
-+int explosionflashtexture6;
-+int explosionflashtexture7;
-+int ParticleCount, ParticleCountHigh, CoronaCount, CoronaCountHigh, MotionBlurCount, MotionBlurCountHigh;
-
- extern cvar_t gl_bounceparticles;
-
---- a/vx_stuff.h
-+++ b/vx_stuff.h
-@@ -49,15 +49,15 @@ void InitCoronas(void);
- void InitVXStuff(void);
- void NewStaticLightCorona (coronatype_t type, vec3_t origin, entity_t *serialhint);
-
--int coronatexture;
--int gunflashtexture;
--int explosionflashtexture1;
--int explosionflashtexture2;
--int explosionflashtexture3;
--int explosionflashtexture4;
--int explosionflashtexture5;
--int explosionflashtexture6;
--int explosionflashtexture7;
-+extern int coronatexture;
-+extern int gunflashtexture;
-+extern int explosionflashtexture1;
-+extern int explosionflashtexture2;
-+extern int explosionflashtexture3;
-+extern int explosionflashtexture4;
-+extern int explosionflashtexture5;
-+extern int explosionflashtexture6;
-+extern int explosionflashtexture7;
-
- float CL_TraceLine (vec3_t start, vec3_t end, vec3_t impact, vec3_t normal);
- void WeatherEffect(void);
-@@ -126,7 +126,7 @@ extern cvar_t amf_part_trailwidth;
- extern cvar_t amf_part_trailtype;
-
- void SCR_DrawAMFstats(void);
--int ParticleCount, ParticleCountHigh, CoronaCount, CoronaCountHigh, MotionBlurCount, MotionBlurCountHigh;
-+extern int ParticleCount, ParticleCountHigh, CoronaCount, CoronaCountHigh, MotionBlurCount, MotionBlurCountHigh;
- void CL_CreateBlurs (vec3_t start, vec3_t end, entity_t *ent);
- void CL_UpdateBlurs (void);
-