summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent2018-03-24 21:07:39 +0100
committerVincent2018-03-24 21:07:39 +0100
commitb6f5eb2853baa47b9cef9c0efbacafb928028787 (patch)
tree2962725e319b5425750d9cde037ea9f4051e7d05
parentb9b6fcf7cbd88f100bfe1123a565fc841688147e (diff)
downloadaur-b6f5eb2853baa47b9cef9c0efbacafb928028787.tar.gz
adding an upstream patch for software version display
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--ser-player.pro.patch10
3 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aee92530c33..52dc84c172fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ser-player
pkgdesc = A simple SER files player, a file format used in astronomy.
pkgver = 1.7.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cgarry/ser-player
arch = x86_64
arch = i686
@@ -9,7 +9,9 @@ pkgbase = ser-player
depends = qt5-base
depends = libpng
source = https://github.com/cgarry/ser-player/archive/v1.7.2.tar.gz
+ source = ser-player.pro.patch
sha1sums = b77169046704453c7e22eb591da6b3b0db457534
+ sha1sums = 20da0e25af1fbc3007b9484b61a69de3ab905651
pkgname = ser-player
diff --git a/PKGBUILD b/PKGBUILD
index 687a306f7ba0..d9c7c2ba2631 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vincent Hourdin <aur at vinvin dot tf>
pkgname=ser-player
pkgver=1.7.2
-pkgrel=1
+pkgrel=2
pkgdesc="A simple SER files player, a file format used in astronomy."
url="https://github.com/cgarry/ser-player"
arch=('x86_64' 'i686')
@@ -11,11 +11,12 @@ makedepends=()
conflicts=()
replaces=()
backup=()
-source=("https://github.com/cgarry/ser-player/archive/v1.7.2.tar.gz")
-sha1sums=('b77169046704453c7e22eb591da6b3b0db457534')
+source=("https://github.com/cgarry/ser-player/archive/v1.7.2.tar.gz" "ser-player.pro.patch")
+sha1sums=('b77169046704453c7e22eb591da6b3b0db457534' '20da0e25af1fbc3007b9484b61a69de3ab905651')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ patch < ../ser-player.pro.patch
qmake-qt5 ser-player.pro DEFINES+=DISABLE_NEW_VERSION_CHECK CONFIG+=release APPIMAGE=
make
}
diff --git a/ser-player.pro.patch b/ser-player.pro.patch
new file mode 100644
index 000000000000..5057c8e66687
--- /dev/null
+++ b/ser-player.pro.patch
@@ -0,0 +1,10 @@
+--- ser-player.pro.old 2018-03-20 09:55:34.443523596 +0000
++++ ser-player.pro 2018-03-20 09:56:33.773882240 +0000
+@@ -50,6 +50,7 @@
+ APP_VERSION=$${APP_VERSION}."dirty"
+ }
+
++APP_VERSION="v1.7.2"
+ message("Version: $${APP_VERSION}")
+ DEFINES += APP_VERSION_STRING=\\\"$${APP_VERSION}\\\"
+