summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Makles2023-02-16 17:29:46 +0000
committerPaul Makles2023-02-16 17:29:46 +0000
commitb70b7a07783ddf633576647322188e6bc5bf9fa5 (patch)
treefeac33f8f87b2597ffbfded46143dc3d9b7a39b6
parent30feba754892441d4c562c80ad0ba5e72774f90d (diff)
downloadaur-b70b7a07783ddf633576647322188e6bc5bf9fa5.tar.gz
chore: update obs-studio to v29.0.2
chore: merge in changes to patches
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD46
-rw-r--r--ignore_unused_submodules.patch19
-rw-r--r--linux-capture_pipewire.patch53
4 files changed, 51 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9502a0a7a36..613e1371a0d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-studio-ftl
pkgdesc = Free, open source software for live streaming and recording (with FTL protocol support)
- pkgver = 27.2.0
+ pkgver = 29.0.2
pkgrel = 1
url = https://obsproject.com
arch = x86_64
@@ -19,7 +19,7 @@ pkgbase = obs-studio-ftl
depends = mbedtls
depends = rnnoise
depends = pciutils
- depends = qt5-svg
+ depends = qt6-svg
depends = curl
depends = jack
depends = gtk-update-icon-cache
@@ -35,9 +35,11 @@ pkgbase = obs-studio-ftl
optdepends = v4l2loopback-dkms: virtual camera support
provides = obs-studio
conflicts = obs-studio
- source = obs-studio-27.2.0.tar.gz::https://github.com/jp9000/obs-studio/archive/27.2.0.tar.gz
+ source = obs-studio-ftl-29.0.2.tar.gz::https://github.com/jp9000/obs-studio/archive/29.0.2.tar.gz
source = fix_python_binary_loading.patch
- md5sums = 2b57d1a86dee33786f36b0effa153083
- md5sums = 051b90f05e26bff99236b8fb1ad377d1
+ source = ignore_unused_submodules.patch
+ sha256sums = 0e6260800b80c3fc9f67c4c3fb12ffae740ab1dd188e526a55e0fc8949168db2
+ sha256sums = bdfbd062f080bc925588aec1989bb1df34bf779cc2fc08ac27236679cf612abd
+ sha256sums = 60b0ee1f78df632e1a8c13cb0a7a5772b2a4b092c4a2a78f23464a7d239557c3
pkgname = obs-studio-ftl
diff --git a/PKGBUILD b/PKGBUILD
index 1fb64f41eadf..06747c013c96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Maintainer: Pawel Makles <me@insrt.uk>
+# Contributor: Sefa Eyeoglu <contact@scrumplex.net>
# Contributor: Jonathan Steel <jsteel at archlinux.org>
# Contributor: Benjamin Klettbach <b.klettbach@gmail.com>
_pkgname=obs-studio
pkgname=obs-studio-ftl
-pkgver=27.2.0
+pkgver=29.0.2
pkgrel=1
pkgdesc="Free, open source software for live streaming and recording (with FTL protocol support)"
arch=('x86_64')
url="https://obsproject.com"
license=('GPL2')
depends=('ffmpeg' 'jansson' 'libxinerama' 'libxkbcommon-x11' 'mbedtls' 'rnnoise' 'pciutils'
- 'qt5-svg' 'curl' 'jack' 'gtk-update-icon-cache' 'pipewire' 'libxcomposite' 'ftl-sdk')
+ 'qt6-svg' 'curl' 'jack' 'gtk-update-icon-cache' 'pipewire' 'libxcomposite' 'ftl-sdk')
makedepends=('cmake' 'libfdk-aac' 'x264' 'swig' 'python' 'luajit' 'sndio')
optdepends=('libfdk-aac: FDK AAC codec support'
'libva-intel-driver: hardware encoding'
@@ -22,32 +23,35 @@ optdepends=('libfdk-aac: FDK AAC codec support'
'v4l2loopback-dkms: virtual camera support')
provides=($_pkgname)
conflicts=($_pkgname)
-source=($_pkgname-$pkgver.tar.gz::https://github.com/jp9000/obs-studio/archive/$pkgver.tar.gz
- fix_python_binary_loading.patch)
-md5sums=('2b57d1a86dee33786f36b0effa153083'
- '051b90f05e26bff99236b8fb1ad377d1')
+source=($pkgname-$pkgver.tar.gz::https://github.com/jp9000/obs-studio/archive/$pkgver.tar.gz
+ fix_python_binary_loading.patch
+ ignore_unused_submodules.patch)
+sha256sums=('0e6260800b80c3fc9f67c4c3fb12ffae740ab1dd188e526a55e0fc8949168db2'
+ 'bdfbd062f080bc925588aec1989bb1df34bf779cc2fc08ac27236679cf612abd'
+ '60b0ee1f78df632e1a8c13cb0a7a5772b2a4b092c4a2a78f23464a7d239557c3')
prepare() {
cd $_pkgname-$pkgver
patch -Np1 < "$srcdir"/fix_python_binary_loading.patch
+ patch -Np1 < "$srcdir"/ignore_unused_submodules.patch
}
build() {
- cd $_pkgname-$pkgver
-
- mkdir -p build; cd build
-
- cmake -DCMAKE_INSTALL_PREFIX="/usr" \
- -DBUILD_BROWSER=OFF \
- -DBUILD_VST=OFF \
- -DDISABLE_VLC=ON \
- -DOBS_VERSION_OVERRIDE="$pkgver-$pkgrel" ..
-
- make
+ cmake -B build -S $_pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_BROWSER=OFF \
+ -DENABLE_VST=ON \
+ -DENABLE_VLC=OFF \
+ -DENABLE_NEW_MPEGTS_OUTPUT=OFF \
+ -DENABLE_AJA=OFF \
+ -DENABLE_JACK=ON \
+ -DENABLE_LIBFDK=ON \
+ -DOBS_VERSION_OVERRIDE="$pkgver-$pkgrel" \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- cd $_pkgname-$pkgver/build
-
- make install DESTDIR="$pkgdir"
+ DESTDIR="$pkgdir" cmake --install build
}
diff --git a/ignore_unused_submodules.patch b/ignore_unused_submodules.patch
new file mode 100644
index 000000000000..bf84758b9bc2
--- /dev/null
+++ b/ignore_unused_submodules.patch
@@ -0,0 +1,19 @@
+--- a/plugins/CMakeLists.txt.orig 2022-09-24 09:05:46.308250388 +0100
++++ b/plugins/CMakeLists.txt 2022-09-24 09:06:04.978206849 +0100
+@@ -61,7 +61,6 @@
+ add_subdirectory(sndio)
+ add_subdirectory(obs-vst)
+
+- check_obs_browser()
+ elseif(OS_FREEBSD)
+ add_subdirectory(linux-capture)
+ add_subdirectory(linux-pulseaudio)
+@@ -84,8 +83,6 @@
+
+ if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/obs-websocket/CMakeLists.txt)
+ add_subdirectory(obs-websocket)
+-else()
+- obs_status(FATAL_ERROR "obs-websocket submodule not available.")
+ endif()
+
+ add_subdirectory(image-source)
diff --git a/linux-capture_pipewire.patch b/linux-capture_pipewire.patch
deleted file mode 100644
index 6ead6ced7fb1..000000000000
--- a/linux-capture_pipewire.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From ef0540c0d7df64b6cb148c80d566281a4ff3ba5c Mon Sep 17 00:00:00 2001
-From: Georges Basile Stavracas Neto <georges.stavracas@gmail.com>
-Date: Fri, 17 Sep 2021 11:59:53 -0300
-Subject: [PATCH] linux-capture: Lookup session handle without typechecks
-
-g_variant_lookup() obligatorily receives the type of the variant to
-lookup. This function is used when retrieving the session handle
-from the portal's response, and the variant type passed is "s" (a
-string).
-
-However, xdg-desktop-portal had a bug: the documentation explicitly
-mentions that the session handle is an object path (of variant type
-"o"), but it passed a string (of variant type "s"). This mismatch
-was fixed in the xdg-desktop-portal release 1.10 [1], but that broke
-the PipeWire capture code, which was passing specifically the "s"
-value to the variant lookup.
-
-Fix this by not checking the variant type at all. Object paths ("o")
-are simply strings with a few extra checks, and we don't actually need
-to perform these checks.
-
-This change probably broke other apps, and that makes me extremely sad :(
-
-[1] https://github.com/flatpak/xdg-desktop-portal/pull/609
----
- plugins/linux-capture/pipewire.c | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/plugins/linux-capture/pipewire.c b/plugins/linux-capture/pipewire.c
-index 848b0fbca13..655e5183dba 100644
---- a/plugins/linux-capture/pipewire.c
-+++ b/plugins/linux-capture/pipewire.c
-@@ -958,6 +958,7 @@ static void on_create_session_response_received_cb(
- UNUSED_PARAMETER(interface_name);
- UNUSED_PARAMETER(signal_name);
-
-+ g_autoptr(GVariant) session_handle_variant = NULL;
- g_autoptr(GVariant) result = NULL;
- struct dbus_call_data *call = user_data;
- obs_pipewire_data *obs_pw = call->obs_pw;
-@@ -975,8 +976,10 @@ static void on_create_session_response_received_cb(
-
- blog(LOG_INFO, "[pipewire] screencast session created");
-
-- g_variant_lookup(result, "session_handle", "s",
-- &obs_pw->session_handle);
-+ session_handle_variant =
-+ g_variant_lookup_value(result, "session_handle", NULL);
-+ obs_pw->session_handle =
-+ g_variant_dup_string(session_handle_variant, NULL);
-
- select_source(obs_pw);
- }