summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2019-02-05 10:27:43 +0300
committersurefire2019-02-05 10:27:43 +0300
commitb726f94c7785fa4e63c09555fcc3b3e0f645a8bf (patch)
tree77ddc34d3a0087dc67ddbbd3b6d900740ff9d4ef
parent32cc46073370b1d8fbf4b19d4e57292f1b7b25ca (diff)
downloadaur-b726f94c7785fa4e63c09555fcc3b3e0f645a8bf.tar.gz
upgpkg: litecoin-git 0.16.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
-rw-r--r--litecoin.tmpfiles2
-rw-r--r--litecoind.service36
4 files changed, 42 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cc0add3cfb8..af30cf38ef38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = litecoin-git
- pkgver = 0.16.0+0+g514e0681d
+ pkgver = 0.16.3+6+g82cacfef8
pkgrel = 1
url = http://www.litecoin.org/
- arch = i686
arch = x86_64
license = MIT
makedepends = git
@@ -18,12 +17,10 @@ pkgbase = litecoin-git
source = litecoin-qt.desktop
source = litecoind.service
source = litecoin.sysusers
- source = litecoin.tmpfiles
sha256sums = SKIP
sha256sums = ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96
- sha256sums = ca335c82437df8b4587384ae39b35249df314bae39d5ed54d16050e98ce1e8fc
+ sha256sums = 98f5a1b28fe13b9093fa89cfe56bb84af09ff5f0d6e9ca196ec02d6dd826ca88
sha256sums = a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db
- sha256sums = 9e4506935cbabaa01a74768cfc89435305ec720ab0e4cc36b5608817f40e95eb
pkgname = litecoin-daemon-git
pkgdesc = Litecoin is a peer-to-peer network based digital currency - daemon
diff --git a/PKGBUILD b/PKGBUILD
index 1a972bee92d5..94f7962368b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgbase=litecoin-git
pkgname=('litecoin-daemon-git' 'litecoin-cli-git' 'litecoin-qt-git' 'litecoin-tx-git')
-pkgver=0.16.0+0+g514e0681d
+pkgver=0.16.3+6+g82cacfef8
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.litecoin.org/"
makedepends=('git' 'boost' 'libevent' 'qt5-base' 'qt5-tools' 'qrencode' 'miniupnpc' 'protobuf' 'zeromq')
license=('MIT')
@@ -14,26 +14,29 @@ source=(
'litecoin-qt.desktop'
'litecoind.service'
'litecoin.sysusers'
- 'litecoin.tmpfiles'
)
sha256sums=('SKIP'
'ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96'
- 'ca335c82437df8b4587384ae39b35249df314bae39d5ed54d16050e98ce1e8fc'
- 'a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db'
- '9e4506935cbabaa01a74768cfc89435305ec720ab0e4cc36b5608817f40e95eb')
+ '98f5a1b28fe13b9093fa89cfe56bb84af09ff5f0d6e9ca196ec02d6dd826ca88'
+ 'a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db')
pkgver() {
- cd "$pkgbase"
- git describe --long --tags | sed 's/-/+/g; s/^v//'
+ cd "$pkgbase"
+ git describe --long --tags | sed 's/-/+/g; s/^v//'
}
build() {
cd "$pkgbase"
./autogen.sh
- ./configure --prefix=/usr --with-gui=qt5 --with-incompatible-bdb
+ ./configure --prefix=/usr --with-gui=qt5 --with-incompatible-bdb --disable-gui-tests
make
}
+check() {
+ cd "$pkgbase"
+ make check
+}
+
package_litecoin-qt-git() {
pkgdesc="Litecoin is a peer-to-peer network based digital currency - Qt"
depends=(boost-libs desktop-file-utils libevent qt5-base miniupnpc qrencode protobuf zeromq)
@@ -68,8 +71,6 @@ package_litecoin-daemon-git() {
"$pkgdir/usr/lib/systemd/system/litecoind.service"
install -Dm644 "$srcdir/litecoin.sysusers" \
"$pkgdir/usr/lib/sysusers.d/litecoin.conf"
- install -Dm644 "$srcdir/litecoin.tmpfiles" \
- "$pkgdir/usr/lib/tmpfiles.d/litecoin.conf"
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
diff --git a/litecoin.tmpfiles b/litecoin.tmpfiles
deleted file mode 100644
index 4dc92a8fddf4..000000000000
--- a/litecoin.tmpfiles
+++ /dev/null
@@ -1,2 +0,0 @@
-d /var/lib/litecoin 0770 litecoin litecoin - -
-d /etc/litecoin 0770 litecoin litecoin - -
diff --git a/litecoind.service b/litecoind.service
index b8a0f82959fb..a5f10107f3fa 100644
--- a/litecoind.service
+++ b/litecoind.service
@@ -5,18 +5,38 @@ After=network.target
[Service]
User=litecoin
Group=litecoin
+ConfigurationDirectory=litecoin
+RuntimeDirectory=litecoin
+StateDirectory=litecoin
+StateDirectoryMode=0700
Type=forking
-PIDFile=/var/lib/litecoind/litecoind.pid
-ExecStart=/usr/bin/litecoind -daemon -pid=/var/lib/litecoind/litecoind.pid \
--conf=/etc/litecoin/litecoin.conf -datadir=/var/lib/litecoind -disablewallet
+PIDFile=litecoin/litecoind.pid
+ExecStart=/usr/bin/litecoind -daemon \
+ -conf=${CONFIGURATION_DIRECTORY}/litecoin.conf \
+ -pid=${RUNTIME_DIRECTORY}/litecoind.pid \
+ -datadir=${STATE_DIRECTORY}
+Restart=on-failure
-Restart=always
+# Hardening measures
+####################
+
+# Provide a private /tmp and /var/tmp.
PrivateTmp=true
-TimeoutStopSec=60s
-TimeoutStartSec=2s
-StartLimitInterval=120s
-StartLimitBurst=5
+
+# Mount /usr, /boot/ and /etc read-only for the process.
+ProtectSystem=full
+
+# Disallow the process and all of its children to gain
+# new privileges through execve().
+NoNewPrivileges=true
+
+# Use a new /dev namespace only populated with API pseudo devices
+# such as /dev/null, /dev/zero and /dev/random.
+PrivateDevices=true
+
+# Deny the creation of writable and executable memory mappings.
+MemoryDenyWriteExecute=true
[Install]
WantedBy=multi-user.target