summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Rauter2018-09-06 12:48:18 +0200
committerGabriel Rauter2018-09-06 12:48:18 +0200
commitb73914b51086515453e5f6a495a680fd17317468 (patch)
treea2362c56da6b3b41f8b02fe4d2c3be854df30e1e
parentbc954326c1a3468c5f26a0e31adb6055dfcd4a29 (diff)
downloadaur-b73914b51086515453e5f6a495a680fd17317468.tar.gz
fix building with vala >= 0.42
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-build-with-vala-0.42.patch25
-rw-r--r--PKGBUILD12
3 files changed, 37 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0970b7bca442..6ad7a0822882 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-usage-git
pkgdesc = GNOME application to view information about use of system resources
- pkgver = 3.28.0.8.gd3af0a0
+ pkgver = 3.28.0.26.g3e1b5bf
pkgrel = 1
url = https://wiki.gnome.org/Apps/Usage
arch = i686
@@ -17,7 +17,9 @@ pkgbase = gnome-usage-git
provides = gnome-usage
conflicts = gnome-usage
source = git+https://gitlab.gnome.org/GNOME/gnome-usage.git
+ source = 0001-Fix-build-with-vala-0.42.patch
sha256sums = SKIP
+ sha256sums = 9ffe8de8386f5f4aaadea3bca74509b38649ff98124e0f9b7dd37580c854ec34
pkgname = gnome-usage-git
diff --git a/0001-Fix-build-with-vala-0.42.patch b/0001-Fix-build-with-vala-0.42.patch
new file mode 100644
index 000000000000..f1dcec969a77
--- /dev/null
+++ b/0001-Fix-build-with-vala-0.42.patch
@@ -0,0 +1,25 @@
+From e3ba0c0bdb5c48b5076a327bd31b2877b1b68e00 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Wed, 22 Aug 2018 10:54:08 +0200
+Subject: [PATCH] Fix build with vala 0.42
+
+---
+ src/speedometer.vala | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/speedometer.vala b/src/speedometer.vala
+index 9d3b3f6..d78a26d 100644
+--- a/src/speedometer.vala
++++ b/src/speedometer.vala
+@@ -43,7 +43,7 @@ namespace Usage
+
+ _percentage = value;
+ }
+- default = 0; }
++ }
+
+ construct {
+ css_provider = new Gtk.CssProvider();
+--
+2.17.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 57ab96258a15..8847474a6963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gnome-usage
pkgname=$_pkgname-git
-pkgver=3.28.0.8.gd3af0a0
+pkgver=3.28.0.26.g3e1b5bf
pkgrel=1
pkgdesc="GNOME application to view information about use of system resources"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -14,14 +14,20 @@ makedepends=(git meson vala)
optdepends=('accountsservice: show user tags for processes')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://gitlab.gnome.org/GNOME/$_pkgname.git")
-sha256sums=('SKIP')
+source=("git+https://gitlab.gnome.org/GNOME/$_pkgname.git"
+ "0001-Fix-build-with-vala-0.42.patch")
+sha256sums=('SKIP'
+ '9ffe8de8386f5f4aaadea3bca74509b38649ff98124e0f9b7dd37580c854ec34')
pkgver() {
cd $_pkgname
git describe --tags | sed 's/^v//;s/-/./g;s/_/./g;'
}
+prepare() {
+ git -C $_pkgname apply $srcdir/0001-Fix-build-with-vala-0.42.patch
+}
+
build() {
arch-meson $_pkgname build
ninja -C build