summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorflorianmw2018-10-15 12:22:20 +0200
committerflorianmw2018-10-15 12:22:20 +0200
commitb74de019dc5fe208166bac1aa63c6afb06722a6e (patch)
tree4722fec6eb28a6b66648668ec08f93ac181debcb
downloadaur-b74de019dc5fe208166bac1aa63c6afb06722a6e.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bb9bda47cef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = automathemely
+ pkgdesc = Simple, set-and-forget python application for changing between GNOME themes according to light and dark hours.
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/C2N14/AutomaThemely
+ arch = any
+ license = GPL-3.0
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/C2N14/AutomaThemely/archive/v1.2.tar.gz
+ sha256sums = 3616d85cc6d910eda718efa8834f594533d053d6269bc11d01a7bdebe5f07bfc
+
+pkgname = automathemely
+ depends = python
+ depends = python-astral
+ depends = python-tzlocal
+ depends = python-schedule
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec16dfb4eabd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: florianmw <flo@i-z-i.net>
+
+pkgname=('automathemely')
+_name='AutomaThemely'
+pkgver='1.2'
+pkgrel=1
+pkgdesc="Simple, set-and-forget python application for changing between GNOME themes according to light and dark hours."
+url="https://github.com/C2N14/AutomaThemely"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL-3.0')
+arch=('any')
+source=("https://github.com/C2N14/${_name}/archive/v${pkgver}.tar.gz")
+sha256sums=('3616d85cc6d910eda718efa8834f594533d053d6269bc11d01a7bdebe5f07bfc')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=('python-astral' 'python-tzlocal' 'python-schedule')
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}