summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduard Toloza2019-03-26 13:03:32 -0500
committerEduard Toloza2019-03-26 13:03:32 -0500
commitb76493e1c8d528e83fa16a4600e7ad782426b684 (patch)
treefbdeacffd73a86b63aac17828b0ddfa6fbc8ae61
downloadaur-b76493e1c8d528e83fa16a4600e7ad782426b684.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--upcheck.install3
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f37a0013066d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = upcheck
+ pkgdesc = Checker for ArchLinux available updates and send it via notify-rust.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.com/edu4rdshl/upcheck
+ install = upcheck.install
+ arch = x86_64
+ license = GPL3
+ depends = pacman-contrib
+ source = https://gitlab.com/edu4rdshl/upcheck/-/archive/0.1.0/upcheck-0.1.0.tar.gz
+ source = upcheck.install
+ sha256sums = 299F590D967CD98A1E658D6CD4226B1D37B9A5DFF8CABBB5D00BC09072D61C28
+ sha256sums = SKIP
+
+pkgname = upcheck
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..147ddba45fd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Eduard Toloza edu4rdshl@securityhacklabs.net
+
+pkgname=upcheck
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Checker for ArchLinux available updates and send it via notify-rust.'
+arch=('x86_64')
+url="https://gitlab.com/edu4rdshl/upcheck"
+license=('GPL3')
+depends=('pacman-contrib')
+source=("https://gitlab.com/edu4rdshl/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "$pkgname.install")
+sha256sums=('299F590D967CD98A1E658D6CD4226B1D37B9A5DFF8CABBB5D00BC09072D61C28'
+ 'SKIP')
+install="$pkgname.install"
+
+package() {
+ cd $pkgname-$pkgver
+ install -dm 755 "$pkgdir/etc/systemd/system/"
+
+ install -Dm 755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm 755 README.md "$pkgdir/usr/share/doc/$pkgname/README"
+ cp $pkgname.{service,timer} "$pkgdir/etc/systemd/system/"
+}
diff --git a/upcheck.install b/upcheck.install
new file mode 100644
index 000000000000..2cc00bb3da6f
--- /dev/null
+++ b/upcheck.install
@@ -0,0 +1,3 @@
+post_install () {
+ echo "To get it working, you need to enable the upcheck.timer unit via systemd."
+} \ No newline at end of file