summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmanuDel-diavolo2020-09-07 13:07:42 +0000
committerAmanuDel-diavolo2020-09-07 19:17:04 +0000
commitb794609bf75e8642362a160735364355c2eaea9d (patch)
tree94f9bf9c0487126b74a57c7339f444504ad4e747
parentb9a9291593ec4ed07ddb47e9d3c31ba418245174 (diff)
downloadaur-b794609bf75e8642362a160735364355c2eaea9d.tar.gz
moved to rhel version of the package
added "PROLIANT ESSENTIAL SOFTWARE" license stripped the binary
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
2 files changed, 40 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6539b283b778..88446808668e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = ssacli
- pkgdesc = HP Command Line Smart Storage Administrator
- pkgver = 4.15_6.0
+ pkgver = 4.17.6.0
pkgrel = 1
- url = https://downloads.linux.hpe.com/SDR/downloads/mcp
+ url = https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_9697c6899a664d02b9c3436674
arch = x86_64
groups = hpproliant
- license = CUSTOM
- depends = bash
+ license = custom:HPE End User License Agreement – Enterprise Version
+ license = custom:PROLIANT ESSENTIALS SOFTWARE
+ depends = sh
replaces = hpacucli
replaces = hpssacli
- source = https://downloads.linux.hpe.com/SDR/repo/mcp/centos/7/x86_64/current/ssacli-4.15-6.0.x86_64.rpm
- sha256sums = 80632df2bf157cd95dc935e3d5d582aec397399d3336a541defd302d5a8b2b3b
+ source = https://downloads.hpe.com/pub/softlib2/software1/pubsw-linux/p1857046646/v174193/ssacli-4.17-6.0.x86_64.rpm
+ source = https://downloads.linux.hpe.com/SDR/downloads/mcp/EULA.txt
+ sha256sums = 844403b362a51ddc2d21d88cad0a5c17e2e488bab60acf49c45fabba10a10e87
+ sha256sums = eafd42b725d5fabea0070c67b2a0dd7bc0f4035a6dae57c3edcf665e60abd96e
pkgname = ssacli
diff --git a/PKGBUILD b/PKGBUILD
index 039297669545..8232791aa1ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,39 @@
-# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
-
pkgname=ssacli
-pkgver=4.15_6.0
+pkgver=4.17.6.0
pkgrel=1
-pkgdesc="HP Command Line Smart Storage Administrator"
-arch=(x86_64)
-url="https://downloads.linux.hpe.com/SDR/downloads/mcp"
-depends=(bash)
+pkgdesk="The HPE Smart Storage Administrator CLI is a commandline-based disk configuration program that helps you configure, manage, diagnose, and monitor HPE ProLiant Smart Array Controllers"
+arch=('x86_64')
+url="https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_9697c6899a664d02b9c3436674"
replaces=(hpacucli hpssacli)
groups=(hpproliant)
-license=("CUSTOM")
+license=('custom:HPE End User License Agreement – Enterprise Version' 'custom:PROLIANT ESSENTIALS SOFTWARE')
+depends=('sh')
+
+sha256sums=("844403b362a51ddc2d21d88cad0a5c17e2e488bab60acf49c45fabba10a10e87"
+ "eafd42b725d5fabea0070c67b2a0dd7bc0f4035a6dae57c3edcf665e60abd96e")
-source=("https://downloads.linux.hpe.com/SDR/repo/mcp/centos/7/x86_64/current/$pkgname-${pkgver//_/-}.x86_64.rpm")
-sha256sums=('80632df2bf157cd95dc935e3d5d582aec397399d3336a541defd302d5a8b2b3b')
+source=("https://downloads.hpe.com/pub/softlib2/software1/pubsw-linux/p1857046646/v174193/ssacli-4.17-6.0.x86_64.rpm"
+ "https://downloads.linux.hpe.com/SDR/downloads/mcp/EULA.txt")
package() {
- mv usr/{sbin,bin}
- mv usr/{,share/}man
- install -Dm644 opt/smartstorageadmin/ssacli/bin/ssacli.license "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
- rm opt/smartstorageadmin/ssacli/bin/ssacli.license
- cp -a opt usr "$pkgdir"
+
+ #installing certificates
+ install -D -m644 "${srcdir}/opt/smartstorageadmin/ssacli/bin/ssacli.license" "${pkgdir}/usr/share/licenses/hpssacli/LICENSE_PES"
+ install -D -m644 "EULA.txt" "${pkgdir}/usr/share/licenses/hpssacli/LICENSE_HPE"
+
+ #moving the actual files
+ cp -r "${srcdir}/opt" "${pkgdir}/opt"
+ cp -r "${srcdir}/usr/sbin" "${pkgdir}/usr/bin"
+ cp -r "${srcdir}/usr/man" "${pkgdir}/usr/share/man"
+
+ #striping the binaries
+ chmod 755 "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssacli"
+ chmod 755 "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssascripting"
+ chmod 755 "${pkgdir}/usr/bin/ssacli"
+ chmod 755 "${pkgdir}/usr/bin/ssascripting"
+
+ #striping the binaries
+ strip --strip-unneeded "${pkgdir}/opt/smartstorageadmin/ssacli/bin/rmstr"
+ strip --strip-unneeded "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssacli"
+ strip --strip-unneeded "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssascripting"
}