summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-19 08:22:12 +0100
committersL1pKn072020-03-19 08:22:12 +0100
commitb7a5d1c4a703fca80475a47ef73ea1715359705f (patch)
tree59e8fcc64c14b36bda5289d965b1d4a1543a9d58
downloadaur-b7a5d1c4a703fca80475a47ef73ea1715359705f.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26686460706
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vapoursynth-plugin-xvs-git
+ pkgdesc = Plugin for Vapoursynth: xvs (GIT version)
+ pkgver = r4.75877c8
+ pkgrel = 1
+ url = https://github.com/xyx98/my-vapoursynth-script
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-muvsfunc-git
+ depends = vapoursynth-plugin-tdeintmod-git
+ depends = vapoursynth-plugin-dpid-git
+ depends = vapoursynth-plugin-tonemap-git
+ depends = vapoursynth-plugin-ffms2-git
+ depends = vapoursynth-plugin-lsmashsource-git
+ provides = vapoursynth-plugin-xvs
+ conflicts = vapoursynth-plugin-xvs
+ source = xvs::git+https://github.com/xyx98/my-vapoursynth-script.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-xvs-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06f74287b629
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=xvs
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r4.75877c8
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/xyx98/my-vapoursynth-script'
+license=('GPL')
+depends=('vapoursynth-plugin-muvsfunc-git'
+ # vsfiltermod not work in linux :( https://github.com/sorayuki/VSFilterMod
+ 'vapoursynth-plugin-tdeintmod-git'
+ 'vapoursynth-plugin-dpid-git'
+ 'vapoursynth-plugin-tonemap-git'
+ 'vapoursynth-plugin-ffms2-git'
+ 'vapoursynth-plugin-lsmashsource-git'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/xyx98/my-vapoursynth-script.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+# echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 xvs.py "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+}