summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Filion2024-04-02 13:16:35 -0400
committerMartin Filion2024-04-02 13:16:35 -0400
commitb7b27b0aef6aca180f066a595465a9a1088ec5e7 (patch)
tree79a980bfccf45ea48911d35191669069d82824ef
parent52d1023940a0ae1b975deb791b22952310da6df8 (diff)
downloadaur-b7b27b0aef6aca180f066a595465a9a1088ec5e7.tar.gz
have icons from 16 to 48
-rw-r--r--PKGBUILD4
-rw-r--r--utils.patch23
2 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2897a2fe0d64..287a50747d67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,6 +25,10 @@ build() {
patch src/menu.c < ../menu.patch
patch src/openbox-menu.h < ../openbox-menu.patch
+
+ # Change the icons default resolution from 16x16 to 48x48.
+ patch src/utils.c < ../utils.patch
+
make
}
diff --git a/utils.patch b/utils.patch
new file mode 100644
index 000000000000..10594fbe686f
--- /dev/null
+++ b/utils.patch
@@ -0,0 +1,23 @@
+--- utils.c 2024-04-02 13:02:13.643439616 -0400
++++ utils.c.new 2024-04-02 13:00:25.956771069 -0400
+@@ -198,9 +198,9 @@
+ return g_strdup (name);
+
+ #ifdef WITH_SVG
+- icon_info = gtk_icon_theme_lookup_icon (gtk_icon_theme_get_default(), name, 16, GTK_ICON_LOOKUP_GENERIC_FALLBACK);
++ icon_info = gtk_icon_theme_lookup_icon (gtk_icon_theme_get_default(), name, 48, GTK_ICON_LOOKUP_GENERIC_FALLBACK);
+ #else
+- icon_info = gtk_icon_theme_lookup_icon (gtk_icon_theme_get_default(), name, 16, GTK_ICON_LOOKUP_NO_SVG | GTK_ICON_LOOKUP_GENERIC_FALLBACK);
++ icon_info = gtk_icon_theme_lookup_icon (gtk_icon_theme_get_default(), name, 48, GTK_ICON_LOOKUP_NO_SVG | GTK_ICON_LOOKUP_GENERIC_FALLBACK);
+ #endif
+ g_free (tmp_name);
+ }
+@@ -208,7 +208,7 @@
+
+
+ if (!icon_info) /* 2nd fallback */
+- icon_info = gtk_icon_theme_lookup_icon (gtk_icon_theme_get_default (), "empty", 16, GTK_ICON_LOOKUP_NO_SVG);
++ icon_info = gtk_icon_theme_lookup_icon (gtk_icon_theme_get_default (), "empty", 48, GTK_ICON_LOOKUP_NO_SVG);
+
+ icon = g_strdup (gtk_icon_info_get_filename (icon_info));
+ g_object_unref (icon_info);