summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDct Mei2020-08-05 15:56:11 +0800
committerDct Mei2020-08-05 15:56:11 +0800
commitb7cb2e7ee6811bbab24bd0339de5a745e8f8cef4 (patch)
tree3cdf136e581889464cb075f21edac2d10d184f32
parentd976a797ae2798407abbc023a084af7d374334df (diff)
downloadaur-b7cb2e7ee6811bbab24bd0339de5a745e8f8cef4.tar.gz
feat: v0.22.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bde07129db8a..c591777d8a89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = geph-exit
pkgdesc = Runs on highly secure exit nodes, and handles exit traffic
- pkgver = 0.21.4
+ pkgver = 0.22.2
pkgrel = 1
url = https://github.com/geph-official/geph2
arch = x86_64
groups = geph2
license = GPL3
- makedepends = go-pie
+ makedepends = go
depends = glibc
- source = geph-exit-0.21.4.tar.gz::https://github.com/geph-official/geph2/archive/v0.21.4.tar.gz
+ source = geph-exit-0.22.2.tar.gz::https://github.com/geph-official/geph2/archive/v0.22.2.tar.gz
source = geph-exit.service
- sha512sums = aecf3bb0f5c6cec5a6db9ce9c11174686208f9caca16736a7addeb70e556446ebdb1384a95c6ee440bf8a583de9b609cb2bc1c8a5720a618024fe57b14d9cd18
+ sha512sums = 2595892671915e576aaee8a7a7beb4fbfb8b702520c6525cced9686c39516fa1c8aa38c360a50f7e698a90f68b23a4a24739903e6fbe8b6f695f0a89e5dc0de0
sha512sums = 6d8f4c68a194ace0f70a68d3e3db9e8dac3f0d64a6de4e1551ec4e3554db9926da340ff487369a183dcb5e65046343d786893cda2ad6d786d879634193700d45
pkgname = geph-exit
diff --git a/PKGBUILD b/PKGBUILD
index e9f67566cc0c..991a49674d84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Dct Mei <dctxmei@gmail.com>
+# Co-Maintainer: xosdy <xosdy.t@gmail.com>
+# Co-Maintainer: ohmyarch <ohmyarchlinux@protonmail.com>
pkgname=geph-exit
-pkgver=0.21.4
+pkgver=0.22.2
pkgrel=1
pkgdesc='Runs on highly secure exit nodes, and handles exit traffic'
arch=('x86_64')
@@ -9,14 +11,19 @@ url="https://github.com/geph-official/geph2"
license=('GPL3')
groups=('geph2')
depends=('glibc')
-makedepends=('go-pie')
+makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/geph-official/geph2/archive/v$pkgver.tar.gz"
"geph-exit.service")
-sha512sums=('aecf3bb0f5c6cec5a6db9ce9c11174686208f9caca16736a7addeb70e556446ebdb1384a95c6ee440bf8a583de9b609cb2bc1c8a5720a618024fe57b14d9cd18'
+sha512sums=('2595892671915e576aaee8a7a7beb4fbfb8b702520c6525cced9686c39516fa1c8aa38c360a50f7e698a90f68b23a4a24739903e6fbe8b6f695f0a89e5dc0de0'
'6d8f4c68a194ace0f70a68d3e3db9e8dac3f0d64a6de4e1551ec4e3554db9926da340ff487369a183dcb5e65046343d786893cda2ad6d786d879634193700d45')
build() {
cd "geph2-$pkgver/cmd/$pkgname/"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
go build
}