summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAman Gupta2024-03-27 12:08:16 +0530
committerAman Gupta2024-03-27 12:08:16 +0530
commitb7d0029c00e7c6ba97aeb5540e213b2905736ee0 (patch)
tree9b6b9f8762c3d821b4041a4c604eea3469d42b3c
parent51d66a13ff0c05f5179e7f196d4da529a6752aeb (diff)
downloadaur-b7d0029c00e7c6ba97aeb5540e213b2905736ee0.tar.gz
v8.13.0
-rwxr-xr-x.SRCINFO6
-rw-r--r--ChangeLog53
-rwxr-xr-xPKGBUILD4
3 files changed, 50 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe60ea85a0bc..da5e35e9a824 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = logstash
pkgdesc = Transport and process your logs, events, or other data
- pkgver = 8.12.2
+ pkgver = 8.13.0
pkgrel = 1
url = https://www.elastic.co/logstash/
changelog = ChangeLog
@@ -19,13 +19,13 @@ pkgbase = logstash
backup = etc/logstash/log4j2.properties
backup = etc/logstash/logstash.yml
backup = etc/logstash/pipelines.yml
- source = https://github.com/elastic/logstash/archive/v8.12.2/logstash-8.12.2.tar.gz
+ source = https://github.com/elastic/logstash/archive/v8.13.0/logstash-8.13.0.tar.gz
source = logstash.service
source = logstash@.service
source = logstash-sysuser.conf
source = logstash-tmpfile.conf
source = bundle.config
- md5sums = 8b3a565618a8a5703053c94fcbfe31f6
+ md5sums = 3b7dbdaa8da5c0837ac03e6be6785e6a
md5sums = 4c3efce8ba4da2605c1f2e839e3af55c
md5sums = 54523d10c53cf5461a40a33d775c12c1
md5sums = 7ef5efbe99cf9f4c29a221999ec41248
diff --git a/ChangeLog b/ChangeLog
index 54b3641ed3ca..3c2272a9ee7c 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,15 +1,52 @@
-=Logstash 8.12.2 Release Notes
+Logstash 8.13.0 Release Notes
+New Logstash plugin: Elastic_integration filter
- Set Netty’s maxOrder options to previous default value of 11 #15928
- Add "openssl" to UBI docker images #15929
+With the Logstash Elastic_integration filter, you can take advantage of the features in Elastic integrations without missing out on the advanced processing capabilities offered by Logstash. Together, Elastic integrations and Logstash can help you solve a wide range of use cases, including air gapped environments, data privacy processing, and multiple destinations.
+
+Your Logstash pipeline would include the elastic_agent input, the elastic_integration filter, and the elasticsearch output, in addition to any other plugins you want to use.
+
+Check out Using Logstash with Elastic Integrations and the Elastics_integration filter plugin docs for details.
+Enhancements and notable issues fixed
+
+ Flow metrics added worker_utilization to pipeline-level #15912
+ Ensure that the order of JVM options from both files and environment variables is respected #15997
+
+Changes to bundled plugins
+
+ Packaged filter-elastic_integration as a bundled plugin in preparation for GA. #15769
+ Unbundled logstash-input-imap plugin #15985
Plugins
-Jdbc Integration - 5.4.8
+Elastic_integration Filter - 0.1.6
+
+ The elastic_integration filter is generally available and bundled with Logstash 8.13.0. Using this filter, Logstash can process data collected by Elastic integrations.
+
+ When you configure the filter to point to an Elasticsearch cluster, it auto-detects the event’s data-stream to determine what integration processing (if any) should be executed for each event. It performs that processing inside Logstash without transmitting the event to Elasticsearch. Events that are successfully handled are tagged so that any downstream Elasticsearch output in the Logstash pipeline will not re-run the integration in Elasticsearch.
+ Fixes issue where configured username/password credentials was not sent to Elasticsearch instances that had anonymous access enabled #127
+
+Beats Input - 6.8.0
+
+ Added a new configuration option event_loop_threads to control the threads count of netty event loop #490
+ When multiple beats-input pipelines are defined in a single machine, sometimes the number of thread may lead to a resource problem.
+ By default, netty event loop creates CPU * 2 thread count. This configuration intends to limit or increase the number of threads to be created for the event loop.
+
+Elasticsearch Input - 4.20.1
+
+ Added support to aggregations with a new configuration option response_type #202
+ hits, the default, is to generate one event per returned document, which is the current behavior.
+ aggregations is to allow processing result of aggregations. A single Logstash event will be generated with the contents of the aggregations object of the query’s response.
+
+Tcp Output - 6.2.0
- Update Derby to 10.15.2.1 (built from source) #155
- Update sequel version to >= 5.74.0, that allows the generic jdbc adapter to better handle disconnect errors #153
+ Deprecated SSL settings to comply with Logstash’s naming convention #53
+ Deprecated ssl_enable in favor of ssl_enabled
+ Deprecated ssl_cert in favor of ssl_certificate
+ Deprecated ssl_verify in favor of ssl_client_authentication when mode is server
+ Deprecated ssl_verify in favor of ssl_verification_mode when mode is client
+ Added ssl_cipher_suites configuration
+ Added SSL configuration validations
-Kafka Integration - 11.3.4
+Elasticsearch Output - 11.22.3
- Fix "retries" and "value_serializer" error handling in output plugin #160
+ Fixes an issue where events containing non-unicode strings could fail to serialize correctly when compression is enabled #1169
diff --git a/PKGBUILD b/PKGBUILD
index 2aa0d964e900..9990b69057dc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Aman Gupta <aman.iv0012@gmail.com>
pkgname=logstash
-pkgver=8.12.2
+pkgver=8.13.0
pkgrel=1
pkgdesc="Transport and process your logs, events, or other data"
arch=('x86_64')
@@ -28,7 +28,7 @@ source=(https://github.com/elastic/logstash/archive/v${pkgver}/${pkgname}-${pkgv
logstash-tmpfile.conf
bundle.config)
# noextract=()
-md5sums=('8b3a565618a8a5703053c94fcbfe31f6'
+md5sums=('3b7dbdaa8da5c0837ac03e6be6785e6a'
'4c3efce8ba4da2605c1f2e839e3af55c'
'54523d10c53cf5461a40a33d775c12c1'
'7ef5efbe99cf9f4c29a221999ec41248'