summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2017-10-07 12:30:30 -0400
committerbrent s2017-10-07 12:30:30 -0400
commitb8207dc25bd772612dad390184cb57d92e43035f (patch)
treefff2d56f48353e5f0ae101829763c2db2f068eab
parentedc355637b56fb17438c9a24065d871bd0c4efae (diff)
downloadaur-b8207dc25bd772612dad390184cb57d92e43035f.tar.gz
adding license
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD4
3 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 931fb1e170ec..8a63636de545 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Oct 7 15:38:03 UTC 2017
+# Sat Oct 7 16:30:30 UTC 2017
pkgbase = python-whois
pkgdesc = Whois querying and parsing of domain registration information
pkgver = 0.6.5
- pkgrel = 1
+ pkgrel = 2
url = https://bitbucket.org/richardpenman/pywhois
arch = i686
arch = x86_64
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..521b461902a2
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+Copyright 2011 Richard Baron Penman and contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 75ba5d4628b7..ceb8556ad2ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=python-whois
pkgver=0.6.5
-pkgrel=1
+pkgrel=2
pkgdesc="Whois querying and parsing of domain registration information"
arch=( 'i686' 'x86_64' )
url="https://bitbucket.org/richardpenman/pywhois"
@@ -25,6 +25,7 @@ package_python-whois() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm 0644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_python2-whois() {
@@ -32,4 +33,5 @@ package_python2-whois() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm 0644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}