summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:11:07 +0100
committerSteven Honeyman2015-06-09 19:11:07 +0100
commitb85a4af9c0de6c3c385baae6e53e85ea33e91701 (patch)
tree326f346e2bd987db65907d128fe3ff39de1610d7
downloadaur-b85a4af9c0de6c3c385baae6e53e85ea33e91701.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a03a1a15d28a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wxhexeditor
+ pkgdesc = a free hex editor / disk editor for Linux, Windows and MacOSX
+ pkgver = 0.23
+ pkgrel = 2
+ url = http://wxhexeditor.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = wxgtk
+ source = http://downloads.sourceforge.net/project/wxhexeditor/wxHexEditor/v0.23%20Beta/wxHexEditor-v0.23-src.tar.bz2
+ md5sums = d0e785c95cf40737246e5b2cc4cb7204
+
+pkgname = wxhexeditor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..003cb122907d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+
+pkgname=wxhexeditor
+pkgver=0.23
+pkgrel=2
+pkgdesc="a free hex editor / disk editor for Linux, Windows and MacOSX"
+arch=('i686' 'x86_64')
+url="http://wxhexeditor.sourceforge.net/"
+license=('GPL')
+makedepends=('wxgtk')
+source=("http://downloads.sourceforge.net/project/wxhexeditor/wxHexEditor/v${pkgver}%20Beta/wxHexEditor-v${pkgver}-src.tar.bz2")
+md5sums=('d0e785c95cf40737246e5b2cc4cb7204')
+
+
+build() {
+ cd "$srcdir/wxHexEditor"
+ make CC=gcc CPP=cpp CXX=g++
+}
+
+package() {
+ cd "$srcdir/wxHexEditor"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}