summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitrij D. Czarkoff2015-10-16 12:26:39 +0200
committerDmitrij D. Czarkoff2015-10-16 12:28:17 +0200
commitb8665dbc69c318df5f3170052a615cb6a0265706 (patch)
tree2e962b1625809981067609f6f647c959886d0da6
downloadaur-b8665dbc69c318df5f3170052a615cb6a0265706.tar.gz
Initial revision
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD55
-rw-r--r--cvsync.conf41
-rw-r--r--cvsync.install2
-rw-r--r--cvsync.service9
-rw-r--r--cvsync.timer10
-rw-r--r--cvsyncd.conf41
-rw-r--r--cvsyncd.service12
8 files changed, 197 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3062447fd56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = cvsync
+ pkgdesc = portable CVS repository synchronization utility
+ pkgver = 0.24.19
+ pkgrel = 1
+ url = http://www.cvsync.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = libgcrypt
+ noextract = cvsync.conf
+ noextract = cvsyncd.conf
+ noextract = cvsyncd.service
+ noextract = cvsync.service
+ noextract = cvsync.timer
+ source = cvsync.conf
+ source = cvsyncd.conf
+ source = cvsyncd.service
+ source = cvsync.service
+ source = cvsync.timer
+ md5sums = 7ccdb0492c98733a00d7e53b3394082a
+ md5sums = 0436a56ad2d25661977d6286b304339d
+ md5sums = 3317d5b6bbde39ff5f512b8b69b21ea2
+ md5sums = 70d3e4f6dce199a8b3246f0d1a7d9514
+ md5sums = 0cb407af2e9a818a6ed3087c9130f2db
+
+pkgname = cvsync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1bc25a2acbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=cvsync
+pkgver=0.24.19
+pkgrel=1
+pkgdesc="portable CVS repository synchronization utility"
+arch=('i686' 'x86_64')
+depends=('libgcrypt')
+url="http://www.cvsync.org/"
+license=('BSD')
+source=('cvsync.conf' 'cvsyncd.conf' 'cvsyncd.service' 'cvsync.service' 'cvsync.timer')
+post_install=cvsync.install
+noextract=("${source[@]%%::*}")
+md5sums=('7ccdb0492c98733a00d7e53b3394082a'
+ '0436a56ad2d25661977d6286b304339d'
+ '3317d5b6bbde39ff5f512b8b69b21ea2'
+ '70d3e4f6dce199a8b3246f0d1a7d9514'
+ '0cb407af2e9a818a6ed3087c9130f2db')
+
+_gitroot=https://github.com/cvsync/cvsync
+_gitname=cvsync
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ make HASH_TYPE=libgcrypt
+}
+
+package() {
+ cd "$pkgdir"
+ mkdir -p "etc" "usr/bin" "usr/man/man1" "usr/lib/systemd/system"
+ cd "$srcdir/$_gitname-build"
+ make HASH_TYPE=libgcrypt PREFIX="$pkgdir/usr" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cvsync.conf b/cvsync.conf
new file mode 100644
index 000000000000..f4020d91a34b
--- /dev/null
+++ b/cvsync.conf
@@ -0,0 +1,41 @@
+#
+# Fetch the OpenBSD CVS repository.
+#
+config {
+ # for a list of available servers, see
+ # http://www.openbsd.org/cvsync.html#CVSROOT
+ hostname cvsync.example.org
+ base-prefix /cvs
+ compress
+
+ # the whole repository
+ collection {
+ name openbsd release rcs
+ scanfile /var/cache/cvsync/openbsd
+ }
+
+# # alternatively, fetch only selected parts
+# collection {
+# name openbsd-cvsroot release rcs
+# }
+# collection {
+# name openbsd-ports release rcs
+# }
+# collection {
+# name openbsd-src release rcs
+# }
+# collection {
+# name openbsd-www release rcs
+# }
+# collection {
+# name openbsd-xenocara release rcs
+# }
+#
+# # the X11 and XF4 trees are of historical interest only
+# collection {
+# name openbsd-x11 release rcs
+# }
+# collection {
+# name openbsd-xf4 release rcs
+# }
+}
diff --git a/cvsync.install b/cvsync.install
new file mode 100644
index 000000000000..c1aa2e91fc57
--- /dev/null
+++ b/cvsync.install
@@ -0,0 +1,2 @@
+useradd cvsync
+useradd cvsyncd
diff --git a/cvsync.service b/cvsync.service
new file mode 100644
index 000000000000..e9e6d7392335
--- /dev/null
+++ b/cvsync.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Synchronize CVS trees
+RefuseManualStart=no
+RefuseManualStop=yes
+
+[Service]
+User=cvsync
+Type=oneshot
+ExecStart=/usr/bin/cvsync
diff --git a/cvsync.timer b/cvsync.timer
new file mode 100644
index 000000000000..f5697445ba9f
--- /dev/null
+++ b/cvsync.timer
@@ -0,0 +1,10 @@
+[Unit]
+Description=Periodically synchronize CVS trees
+
+[Timer]
+Persistent=True
+OnUnitActiveSec=1d
+Unit=cvsync.service
+
+[Install]
+WantedBy=timers.target
diff --git a/cvsyncd.conf b/cvsyncd.conf
new file mode 100644
index 000000000000..28aabc28b1c1
--- /dev/null
+++ b/cvsyncd.conf
@@ -0,0 +1,41 @@
+#
+# Distribute the OpenBSD CVS repository.
+#
+config {
+ base-prefix /cvs
+ pidfile /var/run/cvsyncd/cvsyncd.pid
+
+ collection {
+ name openbsd release rcs
+ comment "OpenBSD CVS Repository"
+ scanfile /var/cache/cvsync/openbsd
+ }
+ collection {
+ super openbsd release rcs
+ name openbsd-cvsroot prefix CVSROOT
+ }
+ collection {
+ super openbsd release rcs
+ name openbsd-ports prefix ports
+ }
+ collection {
+ super openbsd release rcs
+ name openbsd-src prefix src
+ }
+ collection {
+ super openbsd release rcs
+ name openbsd-www prefix www
+ }
+ collection {
+ super openbsd release rcs
+ name openbsd-xenocara prefix xenocara
+ }
+ collection {
+ super openbsd release rcs
+ name openbsd-x11 prefix X11
+ }
+ collection {
+ super openbsd release rcs
+ name openbsd-xf4 prefix XF4
+ }
+}
diff --git a/cvsyncd.service b/cvsyncd.service
new file mode 100644
index 000000000000..3ef93a968aa8
--- /dev/null
+++ b/cvsyncd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=CVSync server daemon
+After=network.target
+
+[Service]
+User=cvsyncd
+Type=simple
+ExecStart=/usr/bin/cvsyncd -f
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target