summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-06-15 14:31:56 +1200
committercaltlgin2020-06-15 14:31:56 +1200
commitb8671bcb1df5c04dc699bd500afa4674fa5baae4 (patch)
tree5b7e01e36660dc1e9ee70944fe4ba2687f590431
parent422cfd967c5149f7fb89e450b2b63b1a322633e1 (diff)
downloadaur-b8671bcb1df5c04dc699bd500afa4674fa5baae4.tar.gz
Clean PKGBUILD in lines with packaging guidelines
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD31
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dc7d92a7517..762665f596a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,6 @@ pkgbase = crex
arch = x86_64
license = MIT
makedepends = cmake
- provides = crex
- conflicts = crex
- conflicts = crex-git
source = https://github.com/octobanana/crex/archive/0.2.5.tar.gz
sha256sums = c6a166b7a1e696a7babeaf7c5728eece1624704a18357f827129fc95ef2ecc56
diff --git a/PKGBUILD b/PKGBUILD
index 850f3ee94a41..6d3d76b97025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,29 @@
pkgname=crex
pkgver=0.2.5
-pkgrel=1
-pkgdesc="Explore, test, and check regular expressions in the terminal"
+pkgrel=2
+pkgdesc='Explore, test, and check regular expressions in the terminal'
arch=('x86_64')
-url="https://octobanana.com/software/${pkgname}"
+url='https://octobanana.com/software/crex'
license=('MIT')
-source=("https://github.com/octobanana/${pkgname}/archive/${pkgver}.tar.gz")
makedepends=('cmake')
-provides=("${pkgname}")
-conflicts=("${pkgname}" "${pkgname}-git")
+source=("https://github.com/octobanana/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('c6a166b7a1e696a7babeaf7c5728eece1624704a18357f827129fc95ef2ecc56')
build() {
- cd "${pkgname}-${pkgver}"
- cmake . -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr
- make
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B build -S "${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C build
}
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-} \ No newline at end of file
+ install -Dm755 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}-${pkgver}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 "${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file