summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-02-28 08:16:55 +0100
committerChristoph Fink2023-02-28 08:16:55 +0100
commitb8858575407f7d351236ff7e5f91165837fa8e1d (patch)
tree6d910d1e0af6c3592c78e9a9a2e03ea9d96a8f73
parent49c38234de814fbe3a9ec45e3a25d3855526f605 (diff)
downloadaur-b8858575407f7d351236ff7e5f91165837fa8e1d.tar.gz
upgpkg: r-stringi 1.7.12-1
upstream release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d097abae1aba..464aabe7e1af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = r-stringi
- pkgdesc = Character String Processing Facilities
- pkgver = 1.7.8
- pkgrel = 2
+ pkgdesc = Fast and Portable Character String Processing Facilities
+ pkgver = 1.7.12
+ pkgrel = 1
url = https://cran.r-project.org/package=stringi
arch = i686
arch = x86_64
license = custom
- depends = r>=3.1
depends = icu>=55
- source = https://cran.r-project.org/src/contrib/stringi_1.7.8.tar.gz
- sha256sums = 538918b1cd6ed1d8a2dd5ab146ba800a088e99f93c52dcd82615b6e127478b1c
+ depends = r>=3.1
+ depends = r-cpp11
+ source = https://cran.r-project.org/src/contrib/stringi_1.7.12.tar.gz
+ b2sums = 7d368e7e5bb439c7e64c68f2a26eae4e7b48a109cde617aa75dcbce839794711accaf1725df9033bcf8277d82430436b61de037f02ad6724bb988fe4b5854879
pkgname = r-stringi
diff --git a/PKGBUILD b/PKGBUILD
index 8e603370f030..cf995e0fed79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,28 @@
-# Contributor: peippo <christoph+aur@christophfink.com>
+# Maintainer: peippo <christoph+aur@christophfink.com>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
+
_cranname=stringi
-_cranver=1.7.8
+_cranver=1.7.12
pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=2
-pkgdesc="Character String Processing Facilities"
-arch=(i686 x86_64)
+pkgdesc="Fast and Portable Character String Processing Facilities"
url="https://cran.r-project.org/package=${_cranname}"
-license=(custom)
-depends=("r>=3.1" "icu>=55")
+license=("custom")
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+
+arch=("i686" "x86_64")
+depends=(
+ "icu>=55"
+ "r>=3.1"
+ "r-cpp11"
+)
+optdepends=()
+makedepends=()
+
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=("538918b1cd6ed1d8a2dd5ab146ba800a088e99f93c52dcd82615b6e127478b1c")
+b2sums=('7d368e7e5bb439c7e64c68f2a26eae4e7b48a109cde617aa75dcbce839794711accaf1725df9033bcf8277d82430436b61de037f02ad6724bb988fe4b5854879')
build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"