aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2018-11-07 12:56:52 -0500
committerAlejandro Valdes2018-11-07 12:56:52 -0500
commitb88d731e25710e525913aa6d455564a12c391b13 (patch)
treef0c04b2383d0768cd643d591e7a6d937f4b169ed
parentf9330dcadc53fdd2f0cfb61d0d8430c2cd51bb25 (diff)
downloadaur-b88d731e25710e525913aa6d455564a12c391b13.tar.gz
Updated mozart to 2.0.1
Renamed package to mozart2-compiler-bin
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5909fc177161..a396398746cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = mozart2-compiler
- pkgdesc = An open source implementation of Oz 3.
- pkgver = 2.0.0_alpha.0.4140
+pkgbase = mozart2-compiler-bin
+ pkgdesc = An open source implementation of Oz 3. (Compiler Only)
+ pkgver = 2.0.1
pkgrel = 1
url = https://mozart.github.io/
arch = x86_64
@@ -8,10 +8,11 @@ pkgbase = mozart2-compiler
depends = tk
conflicts = mozart2
conflicts = mozart1-bin
- source = https://github.com/alevalv/mozart2-compiler-archlinux/releases/download/1.0/bin.rpm
+ conflicts = mozart2-compiler
+ source = https://github.com/mozart/mozart2/releases/download/v2.0.1/mozart2-2.0.1-x86_64-linux.rpm
source = https://raw.githubusercontent.com/mozart/mozart2/master/LICENSE.txt
- sha512sums = dbdf8619d41918e7403a8ea3a7759fdc15013c9bece37ce10d16371428f15c66a31be3624175a4d49ce318647200eac56806922ba240935e421e061e32d8690c
+ sha512sums = 92eba2ca12ee8fab50de983fca551fb61c1970b229c6c2e4006e61c2fd569b05b1f645d220ab04c28f196c6ebb63ab51b34fcb1a9b23ca47ecbd3bdf88e67d6e
sha512sums = c21dfa28faa03a703d853416126d2135330919036b33b40c790569bccb9a0fdbb3cd3acde0cd001a84333f7fe25a18d02be970612720d7726b01a26f0317a78b
-pkgname = mozart2-compiler
+pkgname = mozart2-compiler-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0f853aa9adf6..db34f6168be5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Alejandro Valdes <alejandrovaldes@live.com>
-pkgname='mozart2-compiler'
-pkgver='2.0.0_alpha.0.4140'
+pkgname='mozart2-compiler-bin'
+pkgver='2.0.1'
pkgrel=1
-pkgdesc='An open source implementation of Oz 3.'
+pkgdesc='An open source implementation of Oz 3. (Compiler Only)'
arch=('x86_64')
url='https://mozart.github.io/'
license=('BSD')
depends=('tk')
-conflicts=('mozart2' 'mozart1-bin')
-source=(https://github.com/alevalv/mozart2-compiler-archlinux/releases/download/1.0/bin.rpm
+conflicts=('mozart2' 'mozart1-bin' 'mozart2-compiler')
+source=(https://github.com/mozart/mozart2/releases/download/v${pkgver}/mozart2-${pkgver}-x86_64-linux.rpm
https://raw.githubusercontent.com/mozart/mozart2/master/LICENSE.txt)
-sha512sums=('dbdf8619d41918e7403a8ea3a7759fdc15013c9bece37ce10d16371428f15c66a31be3624175a4d49ce318647200eac56806922ba240935e421e061e32d8690c'
+sha512sums=('92eba2ca12ee8fab50de983fca551fb61c1970b229c6c2e4006e61c2fd569b05b1f645d220ab04c28f196c6ebb63ab51b34fcb1a9b23ca47ecbd3bdf88e67d6e'
'c21dfa28faa03a703d853416126d2135330919036b33b40c790569bccb9a0fdbb3cd3acde0cd001a84333f7fe25a18d02be970612720d7726b01a26f0317a78b')
package() {
cd "$srcdir"
rm usr/bin/oz
rm -r usr/share/applications
+ rm -r usr/lib
install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
cp -R usr "$pkgdir"
}