summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxdavidwu2020-04-14 21:37:42 +0800
committerxdavidwu2020-04-14 21:37:42 +0800
commitb8b6c47531358cb5f868132007c9c9ed5b0f445b (patch)
tree1b58075ded2b83c1dbc10ff098c3a5ac1f2d7738
parent574d1685284d1fd6fcdf8f863f14b468254b8a78 (diff)
downloadaur-b8b6c47531358cb5f868132007c9c9ed5b0f445b.tar.gz
fix issue on arch with a patch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--kali-undercover.patch25
3 files changed, 36 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6cdc7959e83..117a93795581 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kali-undercover
pkgdesc = Kali Undercover Mode
pkgver = 2020.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/kalilinux/packages/kali-undercover/
arch = any
license = GPL3
@@ -11,13 +11,16 @@ pkgbase = kali-undercover
depends = xfdesktop
depends = xfwm4
depends = ttf-liberation
+ depends = xfce4-settings
optdepends = xfce4-whiskermenu-plugin: for menu on undercover mode
optdepends = xfce4-datetime-plugin: for date and time on undercover mode
optdepends = xfce4-notifyd: for settings restored notification
optdepends = libnotify: for settings restored notification
optdepends = psmisc: for clearing existing notificaion
source = https://gitlab.com/kalilinux/packages/kali-undercover/-/archive/kali/2020.2.0/kali-undercover-kali-2020.2.0.tar.gz
+ source = kali-undercover.patch
sha256sums = 906e7881da3be1756dcc77bcad2612eb53f2f5a17e1349c24fee060b7f522d14
+ sha256sums = f652a97f81712cfc81ad9f92478e6b6a8470e9097387e4cf4c84dd0b6b4bbdf8
pkgname = kali-undercover
diff --git a/PKGBUILD b/PKGBUILD
index debb635812e7..eaca7002cc2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
pkgname=kali-undercover
pkgver=2020.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Kali Undercover Mode'
arch=('any')
url='https://gitlab.com/kalilinux/packages/kali-undercover/'
license=('GPL3')
-depends=('python-gobject' 'xfce4-session' 'xfce4-panel' 'xfdesktop' 'xfwm4' 'ttf-liberation')
+depends=('python-gobject' 'xfce4-session' 'xfce4-panel' 'xfdesktop' 'xfwm4' 'ttf-liberation' 'xfce4-settings')
optdepends=('xfce4-whiskermenu-plugin: for menu on undercover mode'
'xfce4-datetime-plugin: for date and time on undercover mode'
'xfce4-notifyd: for settings restored notification'
'libnotify: for settings restored notification'
'psmisc: for clearing existing notificaion')
-source=(https://gitlab.com/kalilinux/packages/${pkgname}/-/archive/kali/${pkgver}/${pkgname}-kali-${pkgver}.tar.gz)
-sha256sums=('906e7881da3be1756dcc77bcad2612eb53f2f5a17e1349c24fee060b7f522d14')
+source=(https://gitlab.com/kalilinux/packages/${pkgname}/-/archive/kali/${pkgver}/${pkgname}-kali-${pkgver}.tar.gz
+ 'kali-undercover.patch')
+sha256sums=('906e7881da3be1756dcc77bcad2612eb53f2f5a17e1349c24fee060b7f522d14'
+ 'f652a97f81712cfc81ad9f92478e6b6a8470e9097387e4cf4c84dd0b6b4bbdf8')
package() {
cd ${pkgname}-kali-${pkgver}
+ patch bin/kali-undercover ../kali-undercover.patch
install -d "${pkgdir}/usr"
cp -dr bin "${pkgdir}/usr/bin"
cp -dr share "${pkgdir}/usr/share"
diff --git a/kali-undercover.patch b/kali-undercover.patch
new file mode 100644
index 000000000000..7d6487a2c724
--- /dev/null
+++ b/kali-undercover.patch
@@ -0,0 +1,25 @@
+--- /usr/bin/kali-undercover 2020-03-05 16:03:06.000000000 +0800
++++ /usr/bin/kali-undercover.new 2020-04-14 21:30:44.488616038 +0800
+@@ -17,7 +17,9 @@
+ mkdir -p $DIR
+
+ # Hide existing notifications
+-killall xfce4-notifyd 2> /dev/null
++# Disabled for Arch, new theme does apply on existing notification and if we want to do this,
++# we should make sure it will be up again
++# killall xfce4-notifyd 2> /dev/null
+
+ # TODO remove old code block
+ # Actual functionality moved to desktopconfig.py
+@@ -72,6 +74,11 @@
+ enable_undercover
+ fi
+
++# On Arch, xfsettingsd may die and xfce4-panel needs an extra restart to work
++sleep 1
++xfsettingsd
++xfce4-panel --restart
++
+ if [ $(cat /proc/$PPID/comm) = 'bash' ]
+ then
+ clear