summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Nagy2022-08-09 22:03:53 +0000
committerRoland Nagy2022-08-09 22:03:53 +0000
commitb8be82ef5ea157d0dbc469e8b973cbbd80c9b7a9 (patch)
treef73297f363ca4de272afed4e9e088546e58b0143
parent0b365dabc71b2718b8fcc73e68e33156e49d2876 (diff)
downloadaur-b8be82ef5ea157d0dbc469e8b973cbbd80c9b7a9.tar.gz
use sources from pythonhosted instead of github
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abba4fa8cc8b..4408bcfbf892 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pywhat
pkgdesc = Identify emails, IP addresses and more
pkgver = 5.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/bee-san/pyWhat
arch = any
license = MIT
@@ -11,7 +11,7 @@ pkgbase = python-pywhat
depends = python-click
depends = python-rich
optdepends = python-orjson: faster JSON serialization and deserialization
- source = python-pywhat-5.1.0.tar.gz::https://github.com/bee-san/pyWhat/archive/refs/tags/5.1.0.tar.gz
- sha256sums = 1e8d8052e007c30165b9cb51466dcdc1cfdea555aab0986bf7f11731095f1400
+ source = python-pywhat-5.1.0.tar.gz::https://files.pythonhosted.org/packages/source/p/pywhat/pywhat-5.1.0.tar.gz
+ sha256sums = 8a6f2b3060f5ce9808802b9ca3eaf91e19c932e4eaa03a4c2e5255d0baad85c4
pkgname = python-pywhat
diff --git a/PKGBUILD b/PKGBUILD
index 25aae57d7d5c..41552ed4ca0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,7 @@
pkgname=python-pywhat
pkgver=5.1.0
-_pyproject_version=5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Identify emails, IP addresses and more"
arch=("any")
url="https://github.com/bee-san/pyWhat"
@@ -20,21 +19,21 @@ makedepends=(
optdepends=(
"python-orjson: faster JSON serialization and deserialization"
)
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=("1e8d8052e007c30165b9cb51466dcdc1cfdea555aab0986bf7f11731095f1400")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/pywhat/pywhat-5.1.0.tar.gz")
+sha256sums=("8a6f2b3060f5ce9808802b9ca3eaf91e19c932e4eaa03a4c2e5255d0baad85c4")
build() {
- cd "$srcdir/pyWhat-$pkgver"
+ cd "$srcdir/pywhat-$pkgver"
poetry build
cd dist
- tar xf "pywhat-$_pyproject_version.tar.gz"
- cd "pywhat-$_pyproject_version"
+ tar xf "pywhat-$pkgver.tar.gz"
+ cd "pywhat-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/pyWhat-$pkgver/dist/pywhat-$_pyproject_version"
+ cd "$srcdir/pywhat-$pkgver/dist/pywhat-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 "$srcdir/pyWhat-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/pywhat-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}