summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2023-04-08 18:40:14 +0300
committerBjörn Bidar2023-04-08 18:40:14 +0300
commitb8c3d8a9a9120a479146004049b9ef2bfbc8f498 (patch)
treeeeb2b94074378be898f98246b7933fe5e2422a6d
parent2122584fa9db83262c4737be9efacb13f21eaa77 (diff)
downloadaur-b8c3d8a9a9120a479146004049b9ef2bfbc8f498.tar.gz
Update to 1.1.0
- New upstream releae - Rebase sb2 patches Signed-off-by: Björn Bidar <bjorn.bidar@thaodan.de>
-rw-r--r--.SRCINFO16
-rw-r--r--0001-Add-sb2install-support-to-osc.patch4
-rw-r--r--0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch8
-rw-r--r--0003-Support-synchronous-copyproj.patch12
-rw-r--r--0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch12
-rw-r--r--0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch6
-rw-r--r--PKGBUILD14
7 files changed, 36 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bf94e13f85b..5bef3f353737 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osc
pkgdesc = Command line client for the openSUSE Build Service
- pkgver = 1.0.0b4
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/openSUSE/osc
arch = any
@@ -19,7 +19,7 @@ pkgbase = osc
conflicts = zsh-completion-osc
replaces = osc-bash-completion
replaces = zsh-completion-osc
- source = https://github.com/openSUSE/osc/archive/1.0.0b4.tar.gz
+ source = https://github.com/openSUSE/osc/archive/1.1.0.tar.gz
source = _osc
source = 0001-Add-sb2install-support-to-osc.patch
source = 0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
@@ -27,13 +27,13 @@ pkgbase = osc
source = 0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
source = 0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
source = 0006-Add-architecture-and-scheduler-maps.patch
- sha256sums = 9542585fbddadaaff914996b9e239c00ba6873a9ad4db5b28c00e841c9c582da
+ sha256sums = ccbeb4a812d2518ec26b2509a54689641346d413fe88ad4f9770768c3016b6a7
sha256sums = 2b045e03d2fdce12683ceb9792d491a32f00b256045456412e7bc18c8726218a
- sha256sums = 35ba6d6c03cbb1e437708251969ca8d71376744cdb8fd826fd971645224e1ec5
- sha256sums = 569519d45ef2d87d984e6828c6c2c1bc0aedbc9485ad303fd35d11a249cc2446
- sha256sums = add44ed6f71cadea8f43370ef2dc72516fd148db2e77879091bd812b4b95adc9
- sha256sums = 29e68a3e4142cbef52f2311d2ea3c34472de87b1f6eddf70b9d9cfb8395bd31e
- sha256sums = 0439a28bd3606fb298894c73f7d530090c31bdf638e9f3e4037bc68a36b24089
+ sha256sums = 2fef5c0a42f331fdb892a69a80d036aba5e24921e881e74833018009d29c5649
+ sha256sums = fbd42a43177351f677ed3eef085774c43d545723bc4f8b8bc7add8df57c565c3
+ sha256sums = 5a6cbb6375a83fa4dbb9103725b7e2b1d861edb3249f47f577bea94fac52d0c9
+ sha256sums = 3771bd3660635f193d8250778a01533c4a089d26b6355a8910aa33b9295efbdc
+ sha256sums = df3de96be2dc05b1034539c439fc63cdba4257ca310c801d24a4a72843e60ba9
sha256sums = eae5f978b8385db3acae46df96fc4973f306c4a640389165a8ac54469d370e5b
pkgname = osc
diff --git a/0001-Add-sb2install-support-to-osc.patch b/0001-Add-sb2install-support-to-osc.patch
index e19d36a750b5..20037110634a 100644
--- a/0001-Add-sb2install-support-to-osc.patch
+++ b/0001-Add-sb2install-support-to-osc.patch
@@ -8,7 +8,7 @@ Subject: [PATCH] Add sb2install support to osc
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/osc/build.py b/osc/build.py
-index 36dcd75f02555a238ebcb53388b52e75418af3e9..a93e10716de947b579823a065b6b4d207bc65466 100644
+index e2a5f423ad1059758d1816f4525c99bdf1eca98f..544f159456f1697319f3db4ddb69db294bbd988a 100644
--- a/osc/build.py
+++ b/osc/build.py
@@ -190,12 +190,13 @@ class Buildinfo:
@@ -36,7 +36,7 @@ index 36dcd75f02555a238ebcb53388b52e75418af3e9..a93e10716de947b579823a065b6b4d20
self.mp[i] = node.get(i)
self.mp['buildarch'] = buildarch
-@@ -1398,6 +1400,7 @@ def main(apiurl, opts, argv):
+@@ -1401,6 +1403,7 @@ def main(apiurl, opts, argv):
rpmlist.append('preinstall: ' + ' '.join(bi.preinstall_list) + '\n')
rpmlist.append('vminstall: ' + ' '.join(bi.vminstall_list) + '\n')
diff --git a/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch b/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
index 9c51d3336a26..88640534e85c 100644
--- a/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
+++ b/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
@@ -13,10 +13,10 @@ Subject: [PATCH] Support 'osc copyprj' in api by Islam Amer usage: osc copyprj
2 files changed, 80 insertions(+)
diff --git a/osc/commandline.py b/osc/commandline.py
-index c2a7cbf998e58ca1ee51ef47c3b767e3777bf0c3..797e3ffd5f248285507bbafc59350efe675ce607 100644
+index f0c2b367dcc303b8a7f9727d99a0625166e6d764..55a52d949bf20639a7632ace574c6fd77c97adb4 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -3407,6 +3407,58 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3908,6 +3908,58 @@ Please submit there instead, or use --nodevelproject to force direct submission.
delayed=not opts.no_delay,
print_to="stdout",
)
@@ -76,10 +76,10 @@ index c2a7cbf998e58ca1ee51ef47c3b767e3777bf0c3..797e3ffd5f248285507bbafc59350efe
@cmdln.option('-m', '--message', metavar='TEXT',
help='specify message TEXT')
diff --git a/osc/core.py b/osc/core.py
-index d223caa7e686d9c00b0cbf2fae3ac08d5ada503c..356da278bdae46cbb6639f24e20b3f8b05c5fa5c 100644
+index aa7b36412107eaf716a65846ead0512f25cb9072..5b5f5c10c47d9bf56a290076bc752ff2bb1aea91 100644
--- a/osc/core.py
+++ b/osc/core.py
-@@ -6037,6 +6037,34 @@ def copy_pac(
+@@ -6152,6 +6152,34 @@ def copy_pac(
raise oscerr.APIError('failed to copy: %s' % ', '.join(todo))
return 'Done.'
diff --git a/0003-Support-synchronous-copyproj.patch b/0003-Support-synchronous-copyproj.patch
index c799cca68eaa..246400e6f9bc 100644
--- a/0003-Support-synchronous-copyproj.patch
+++ b/0003-Support-synchronous-copyproj.patch
@@ -9,10 +9,10 @@ Subject: [PATCH] Support synchronous copyproj
2 files changed, 7 insertions(+)
diff --git a/osc/commandline.py b/osc/commandline.py
-index 797e3ffd5f248285507bbafc59350efe675ce607..ee540138cac2c66fd500a0cd1e78e670f57f5c46 100644
+index 55a52d949bf20639a7632ace574c6fd77c97adb4..f7a7512f5a6967980a2433e5c8e95136a97d8257 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -3409,6 +3409,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3910,6 +3910,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
)
@cmdln.option('-b', '--with-binaries', action='store_true',
help='copy the built binaries over to avoid a rebuild')
@@ -21,7 +21,7 @@ index 797e3ffd5f248285507bbafc59350efe675ce607..ee540138cac2c66fd500a0cd1e78e670
@cmdln.option('-x', '--with-history', action='store_true',
help='replicate the history of each package.')
@cmdln.option('-o', '--make-older', action='store_true',
-@@ -3426,6 +3428,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3927,6 +3929,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
The user must be able to create DESTPRJ
@@ -30,7 +30,7 @@ index 797e3ffd5f248285507bbafc59350efe675ce607..ee540138cac2c66fd500a0cd1e78e670
usage:
osc copyprj SOURCEPRJ DESTPRJ
${cmd_option_list}
-@@ -3455,6 +3459,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3956,6 +3960,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
withhistory = opts.with_history,
makeolder = opts.make_older,
resign = opts.re_sign,
@@ -39,10 +39,10 @@ index 797e3ffd5f248285507bbafc59350efe675ce607..ee540138cac2c66fd500a0cd1e78e670
print("done cp")
print(r)
diff --git a/osc/core.py b/osc/core.py
-index 356da278bdae46cbb6639f24e20b3f8b05c5fa5c..64f69acb23a72b7d79c09532a956d930707a0c0e 100644
+index 5b5f5c10c47d9bf56a290076bc752ff2bb1aea91..45a6236d93078ff1e1779d8984c7c01a9385048a 100644
--- a/osc/core.py
+++ b/osc/core.py
-@@ -6061,6 +6061,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
+@@ -6176,6 +6176,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
query['resign'] = '1'
if comment:
query['comment'] = comment
diff --git a/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch b/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
index 7597c6f73c2f..691e483bde7d 100644
--- a/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
+++ b/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
@@ -9,10 +9,10 @@ Subject: [PATCH] Add -p to copyprj to enable copying of prjconf
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/osc/commandline.py b/osc/commandline.py
-index ee540138cac2c66fd500a0cd1e78e670f57f5c46..e6045ed4add369e7cbf52cc95af6d6c2ff90a780 100644
+index f7a7512f5a6967980a2433e5c8e95136a97d8257..3eb0887dab6331f32fd3ed32462685fc94477aca 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -3415,6 +3415,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3916,6 +3916,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
help='replicate the history of each package.')
@cmdln.option('-o', '--make-older', action='store_true',
help='No idea')
@@ -21,7 +21,7 @@ index ee540138cac2c66fd500a0cd1e78e670f57f5c46..e6045ed4add369e7cbf52cc95af6d6c2
@cmdln.option('-r', '--re-sign', action='store_true',
help='re-sign the binaries')
@cmdln.option('-m', '--message', metavar='TEXT',
-@@ -3459,7 +3461,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3960,7 +3962,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
withhistory = opts.with_history,
makeolder = opts.make_older,
resign = opts.re_sign,
@@ -31,10 +31,10 @@ index ee540138cac2c66fd500a0cd1e78e670f57f5c46..e6045ed4add369e7cbf52cc95af6d6c2
print("done cp")
print(r)
diff --git a/osc/core.py b/osc/core.py
-index 64f69acb23a72b7d79c09532a956d930707a0c0e..e5e193cfa98f42f3b1456cca37bd2a19b2855d4c 100644
+index 45a6236d93078ff1e1779d8984c7c01a9385048a..3ce4b2257fa959d0067d950ddc5c88ddafa80eac 100644
--- a/osc/core.py
+++ b/osc/core.py
-@@ -6042,6 +6042,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
+@@ -6157,6 +6157,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
withhistory = False,
makeolder = False,
resign = False,
@@ -43,7 +43,7 @@ index 64f69acb23a72b7d79c09532a956d930707a0c0e..e5e193cfa98f42f3b1456cca37bd2a19
comment = None):
"""
Create a copy of a project.
-@@ -6063,6 +6065,9 @@ def copy_prj(src_apiurl, src_project, dst_project,
+@@ -6178,6 +6180,9 @@ def copy_prj(src_apiurl, src_project, dst_project,
query['comment'] = comment
if now:
query['nodelay'] = '1'
diff --git a/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch b/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
index 1448068b32cd..ee0966072b54 100644
--- a/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
+++ b/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
@@ -14,7 +14,7 @@ Subject: [PATCH] Add support for --rebuild and --chroot-only in build.
2 files changed, 10 insertions(+)
diff --git a/osc/build.py b/osc/build.py
-index a93e10716de947b579823a065b6b4d207bc65466..eea57dd942d196191607eecc655e65690b0e3b51 100644
+index 544f159456f1697319f3db4ddb69db294bbd988a..70f53cb0043b8a8b3d0cbc8a8e5e7cbae4635be4 100644
--- a/osc/build.py
+++ b/osc/build.py
@@ -696,6 +696,12 @@ def main(apiurl, opts, argv):
@@ -31,10 +31,10 @@ index a93e10716de947b579823a065b6b4d207bc65466..eea57dd942d196191607eecc655e6569
buildargs.append('--no-checks')
if not opts.no_changelog:
diff --git a/osc/commandline.py b/osc/commandline.py
-index e6045ed4add369e7cbf52cc95af6d6c2ff90a780..0fc3b87287aad930f73458c665c8e34e8116ab6c 100644
+index 3eb0887dab6331f32fd3ed32462685fc94477aca..c0e85a62405836a4725bffb8888df3bf7b1e2068 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -6538,6 +6538,10 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -7039,6 +7039,10 @@ Please submit there instead, or use --nodevelproject to force direct submission.
help='Copy overlay filesystem to buildroot after installing all RPMs .')
@cmdln.option('--noinit', '--no-init', action='store_true',
help='Skip initialization of build root and start with build immediately.')
diff --git a/PKGBUILD b/PKGBUILD
index 62064b0ad0e2..11ca4b5f52bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor : Patrick McCarty <pnorcks at gmail dot com>
pkgname=osc
-pkgver=1.0.0b4
+pkgver=1.1.0
pkgrel=1
pkgdesc="Command line client for the openSUSE Build Service"
arch=(any)
@@ -33,13 +33,13 @@ source=("https://github.com/openSUSE/${pkgname}/archive/${pkgver}.tar.gz"
0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
0006-Add-architecture-and-scheduler-maps.patch
)
-sha256sums=('9542585fbddadaaff914996b9e239c00ba6873a9ad4db5b28c00e841c9c582da'
+sha256sums=('ccbeb4a812d2518ec26b2509a54689641346d413fe88ad4f9770768c3016b6a7'
'2b045e03d2fdce12683ceb9792d491a32f00b256045456412e7bc18c8726218a'
- '35ba6d6c03cbb1e437708251969ca8d71376744cdb8fd826fd971645224e1ec5'
- '569519d45ef2d87d984e6828c6c2c1bc0aedbc9485ad303fd35d11a249cc2446'
- 'add44ed6f71cadea8f43370ef2dc72516fd148db2e77879091bd812b4b95adc9'
- '29e68a3e4142cbef52f2311d2ea3c34472de87b1f6eddf70b9d9cfb8395bd31e'
- '0439a28bd3606fb298894c73f7d530090c31bdf638e9f3e4037bc68a36b24089'
+ '2fef5c0a42f331fdb892a69a80d036aba5e24921e881e74833018009d29c5649'
+ 'fbd42a43177351f677ed3eef085774c43d545723bc4f8b8bc7add8df57c565c3'
+ '5a6cbb6375a83fa4dbb9103725b7e2b1d861edb3249f47f577bea94fac52d0c9'
+ '3771bd3660635f193d8250778a01533c4a089d26b6355a8910aa33b9295efbdc'
+ 'df3de96be2dc05b1034539c439fc63cdba4257ca310c801d24a4a72843e60ba9'
'eae5f978b8385db3acae46df96fc4973f306c4a640389165a8ac54469d370e5b')
prepare() {