summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2018-08-13 12:43:43 +0200
committerSefa Eyeoglu2018-08-13 12:43:43 +0200
commitb8c44fbac8b2ca18ac1a9ccffb3c778f8beca34e (patch)
treefe083dbfb440c437b97da11bec238763f4acebd5
downloadaur-b8c44fbac8b2ca18ac1a9ccffb3c778f8beca34e.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7142a2726e28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = img-matrix-git
+ pkgdesc = Script that generates tiles from images and combines them in a html file.
+ pkgver = r4.bf02421
+ pkgrel = 1
+ url = https://gitlab.com/Scrumplex/img-matrix
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = bash
+ depends = imagemagick
+ provides = img-matrix
+ conflicts = img-matrix
+ source = git+https://gitlab.com/Scrumplex/img-matrix.git
+ sha512sums = SKIP
+
+pkgname = img-matrix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a1d96e14417
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+pkgname=img-matrix-git
+pkgver=r4.bf02421
+pkgrel=1
+pkgdesc='Script that generates tiles from images and combines them in a html file.'
+arch=('i686' 'x86_64')
+
+url='https://gitlab.com/Scrumplex/img-matrix'
+license=('GPL3')
+
+depends=('bash' 'imagemagick')
+makedepends=('git')
+provides=('img-matrix')
+conflicts=('img-matrix')
+
+source=(
+ "git+https://gitlab.com/Scrumplex/img-matrix.git"
+)
+sha512sums=(
+ "SKIP"
+)
+
+pkgver() {
+ cd "$srcdir/img-matrix"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/img-matrix"
+ install -v -m755 -D "img-matrix" "$pkgdir/usr/bin/img-matrix"
+}